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Welcome

This documentation describes how to create and manage reusable 
InTouch graphics, called SmartSymbols.

To get the most benefit from this documentation, you should have a 
basic understanding of the InTouch HMI and WindowMaker.

This documentation assumes you know how to use Microsoft Windows, 
including how to navigate menus, move from application to 
application, and move objects on the screen. If you need help with 
these tasks, see the Microsoft Help.

You can view this documentation online or you can print it, in part or 
whole, by using the print feature in Adobe Reader.

Documentation Conventions
This documentation uses the following conventions:

Convention Used for

Initial Capitals Paths and file names.

Bold Menus, commands, dialog box names, and 
dialog box options.

Monospace Code samples and display text.
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Technical Support
Wonderware Technical Support offers a variety of support options to 
answer any questions on Wonderware products and their 
implementation.

Before you contact Technical Support, refer to the relevant section(s) 
in this documentation for a possible solution to the problem. If you 
need to contact technical support for help, have the following 
information ready:

• The type and version of the operating system you are using.

• Details of how to recreate the problem.

• The exact wording of the error messages you saw.

• Any relevant output listing from the Log Viewer or any other 
diagnostic applications.

• Details of what you did to try to solve the problem(s) and your 
results.

• If known, the Wonderware Technical Support case number 
assigned to your problem, if this is an ongoing problem.
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Chapter 1

About SmartSymbols

SmartSymbols are Wonderware® InTouch® graphics that are 
converted into reusable templates. Changes that you make to a 
SmartSymbol template propagate to all instances of the SmartSymbol 
throughout the application. This relieves you of the duplicate effort for 
creating, modifying, validating, and re-validating graphics used 
repetitively throughout an application.

SmartSymbols can reference InTouch tags and ArchestrA® attributes. 
A SmartSymbol that references no tags or only InTouch tags is called 
an InTouch SmartSymbol.

A SmartSymbol that references an attribute of one or more ArchestrA 
Automation Objects or ArchestrA Automation Object instances is 
called an ArchestrA SmartSymbol. ArchestrA SmartSymbols may also 
reference InTouch tags.

InTouch and ArchestrA SmartSymbols are different from ArchestrA 
Symbols. ArchestrA Symbols are designed and managed using the 
ArchestrA Integrated Development Environment (IDE).
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If you are using InTouch version 10 or later and are creating new 
graphics, ArchestrA Symbols may be more suitable than 
SmartSymbols for your application. For more information, see About 

InTouch HMI and ArchestrA Integration in the InTouch® HMI and 

ArchestrA® Integration Guide.

SmartSymbol Manager and Library
The SmartSymbol library contains the SmartSymbols for an InTouch 
application. You use the SmartSymbol Manager to import, export, and 
organize the contents of the SmartSymbol library. 

SmartSymbols are stored in a \Symbols folder of the application folder 
of the user's InTouch application.

Reference information about the SmartSymbols in the library is stored 
in an XML file. You should not edit the XML file.

SmartSymbol Instances

 Graphic Cell

SmartSymbol Template
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InTouch SmartSymbols and ArchestrA 
SmartSymbols 

InTouch SmartSymbols are not the same as ArchestrA SmartSymbols. 
ArchestrA Symbols supersede ArchestrA SmartSymbols and are 
developed using the ArchestrA IDE. InTouch SmartSymbols reference 
InTouch tag data. ArchestrA SmartSymbols reference Galaxy object or 
template attributes.

The following figure shows the types of SmartSymbols.

Types of SmartSymbols

InTouch objects

#.###

InTouch cell

#.###

InTouch 
SmartSymbol

#.###

ArchestrA 
SmartSymbol

#.###

InTouch
Application

Window

SmartSymbol 
Manager

Create 
SmartSymbol
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InTouch SmartSymbols
InTouch SmartSymbols are stored under the InTouch Symbols folder 
in the SmartSymbol Manager. 

You can configure animation for the graphical elements in an InTouch 
SmartSymbol using references to local and remote InTouch tags. For 
more information, see Creating SmartSymbol Templates and 
Instances.

ArchestrA SmartSymbols
ArchestrA SmartSymbols are stored under the ArchestrA Symbols 
folder in the SmartSymbol Manager.

Note:  Even though the folder is labeled ArchestrA Symbols, the folder 
contains ArchestrA SmartSymbols, not ArchestrA Symbols.

InTouch SmartSymbol

InTouch TagName 
Dictionary

InTouch 
SmartSymbol

#.###

SmartSymbol 
Manager

No references

Can Reference
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To create ArchestrA SmartSymbols, you select one or more Galaxy 
object templates to define the animation references for the various 
graphical elements. For more information, see Creating SmartSymbol 
Templates and Instances.

Limitations of SmartSymbols
The following are known limitations of SmartSymbols.

• SmartSymbols cannot contain a trend object. If you try to create a 
SmartSymbol that contains a trend object (historical or real-time), 
an error message appears.

• SmartSymbols cannot contain Distributed Alarm Display controls, 
Windows Controls, InTouch ActiveX controls like AlarmViewer, or 
third party ActiveX controls that are configured in an InTouch 
application.

• You cannot browse for ArchestrA instances in a galaxy created 
with Application Server version 1.5. Install Application Server 
version 2.0 or later to browse for ArchestrA instances.

• Generating SmartSymbols with an SPC Chart wizard is not 
supported.

• SmartSymbols cannot reference local script variables.

• The Attribute Browser does not show derived object instances. To 
address this issue, create the derived template in the 
SmartSymbol Manager or create a custom filter in the browser.

ArchestrA SmartSymbol

InTouch TagName 
Dictionary ArchestrA

Automation
Object 

Template

ArchestrA
Automation

Object 
Instance

ArchestrA 
SmartSymbol

#.###

SmartSymbol 
Manager

Optional Can Reference
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Chapter 2

Creating SmartSymbol
Templates and Instances

Using WindowMaker, you can create SmartSymbol templates and 
instances.

You create SmartSymbol templates by drawing one or more graphics 
in WindowMaker, combining them into a cell, and then converting the 
cell into a SmartSymbol. You do not have to connect or link templates 
to InTouch tags or ArchestrA objects.

After you create a SmartSymbol template, you can create an instance 
of the SmartSymbol in an application window.

You can also create ArchestrA object instances from an existing 
ArchestrA SmartSymbol instance to avoid switching between InTouch 
WindowMaker and the ArchestrA Integrated Development 
Environment (IDE).

animation

SmartSymbol 
Template

create 
template

create 
instance

WindowMaker 
Graphic Cell

SmartSymbol 
Instance
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Creating SmartSymbol Templates for Use with 
InTouch Data

InTouch SmartSymbols are created from cells, which can contain 
graphical elements, animation, and references to InTouch tags.

The following procedure specifies that a new window, graphics, and 
cell be created, but you can use an existing window, graphics, or cells 
to create a SmartSymbol.

To create a new InTouch SmartSymbol template

1 Create a new window in WindowMaker.

2 Using the graphics drawing tools and/or Wizards, create a graphic 
or set of graphics that you want to include in your SmartSymbol.

3 Configure the animation link(s) for the graphic(s). 

For instructions, see Animating Objects in the InTouch® HMI 
Visualization Guide.

4 Select all objects to be included in the SmartSymbol template.

5 On the Arrange menu, click Make Cell. 

6 Select the cell you just made.

7 On the Special menu, point to SmartSymbol and click Generate 
SmartSymbol. The InTouch SmartSymbol - Management Mode 
dialog box appears with the new SmartSymbol highlighted.
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By default, the new SmartSymbol is placed in the InTouch 
Symbols top level folder. A default name is automatically assigned 
to the symbol (for example, New Symbol1). 

8 Type a new name or accept the default. You can change the name 
of the SmartSymbol at any time. For more information on 
renaming SmartSymbols, see "Renaming SmartSymbol 
Templates" on page 26. 

9 Click Close. A message appears prompting you to replace the 
graphic cell with new SmartSymbol. Click Yes or No. If you click 
Yes, the graphic cell is replaced by the SmartSymbol. If you click 
No, the graphic cell is unchanged. In either case, the new 
SmartSymbol is stored in the SmartSymbol library and is 
available for future use. 

Creating ArchestrA SmartSymbol Templates
When you create a SmartSymbol from an InTouch graphic cell that 
contains at least one reference to an ArchestrA automation object 
template or instance, you end up with an ArchestrA SmartSymbol.

A reference to an ArchestrA automation template contains a "$" sign.

You can generate SmartSymbol templates that are associated with 
ArchestrA object templates and/or instances.

When you create a SmartSymbol instance on the InTouch window, you 
can instantiate its referenced ArchestrA object template. 

To generate a new ArchestrA SmartSymbol template 

1 Create a new window in WindowMaker.

2 Using the drawing tools and/or Wizards, create graphics that you 
want to make into a SmartSymbol. 

3 Configure the animation link(s) for the graphic(s). 

For instructions on configuring Galaxy source names, see 

Accessing Application Server Data from InTouch in the InTouch® 
HMI Data Management Guide For instructions on configuring 
creating links to ArchestrA attributes, see Animating Objects in 

the InTouch® HMI Visualization Guide.

4 Select the graphics to make into a cell. On the Arrange menu, click 
Make Cell. 

5 On the Special menu, point to SmartSymbol, and click Generate 
SmartSymbol. The SmartSymbol Manager creates the new 
SmartSymbol for Galaxy data and creates an ArchestrA template 
folder if one does not already exist. 
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6 Type in a new name or accept the default name and change it later. 

7 Click Close. A message appears prompting you to replace the 
graphic cell with new SmartSymbol. Click Yes or No. If you click 
Yes, the graphic cell is replaced by the SmartSymbol. If you click 
No, the graphic cell is unchanged. In either case, the new 
SmartSymbol is stored in the SmartSymbol library and is 
available for future use. 

Creating SmartSymbol Instances from InTouch 
SmartSymbol Templates

You can create multiple SmartSymbol instances from a single 
SmartSymbol template. Each instance inherits all references and text 
labels. Before the instance is placed on the InTouch window, you can 
change the references and text labels.

To create a SmartSymbol from an InTouch SmartSymbol 
template

1 Open WindowMaker and open a window where you want to use a 
SmartSymbol. 

2 Click the SmartSymbol Wizard icon. 

3 Click in the WindowMaker window where you want to place the 
symbol. The InTouch SmartSymbol - Select Mode dialog box 
appears.

Note:  By default, the Show Properties Dialog on instantiation check 
box is selected. Clear the check box if you don't want to change any 
references or text labels for the new SmartSymbol instance.
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4 In the InTouch Symbols folder, double-click the SmartSymbol. The 
new symbol appears in the application window. 

If the Show Properties Dialog on instantiation check box is 
selected in the previous step, the SmartSymbol Properties dialog 
box appears.

 

5 In the Instance References column, click the Ellipsis button. The 
Select Tag or Tagname Dictionary dialog box appears. 

6 Select the tag to link to the SmartSymbol. Close the window and 
the SmartSymbol Properties dialog box appears. 

Note:  If you enter a new tagname that is not defined yet, then the 
Tagname Undefined dialog box appears, click OK and define a new tag 
from the Tagname Dictionary.

7 Click OK. The new symbol appears in the application window. 
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Creating SmartSymbol Instances from 
ArchestrA SmartSymbol Templates

You can create multiple ArchestrA SmartSymbol instances from a 
single ArchestrA SmartSymbol template. 

To create a SmartSymbol from an ArchestrA SmartSymbol 
template

1 Click SmartSymbol icon and click in the WindowMaker window 
where you want to place the symbol. The InTouch SmartSymbol - 
Select Mode dialog box appears. 

Note:  By default, the Show Properties Dialog on instantiation check 
box is selected.

2 Click the ArchestrA Symbols folder. The ArchestrA symbols 
appear in the right pane.
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3 Select the SmartSymbol and click OK. The new symbol appears in 
the application window.

If the Show Properties Dialog on instantiation check box is 
selected in the previous step, the SmartSymbol Properties dialog 
box appears.

4 In the ArchestrA Instance text box, you can either:

• Browse for and select an ArchestrA object. 

• Create a new ArchestrA object instance derived from 
associated object template. Enter a name for the instance and 
click New.

The instance attribute references appear in the Instance 
References column. 

Note:  If you did not connect the Galaxy yet, a dialog box appears 
prompting you to enter node name and Galaxy name.

5 In the Instance References column, change the references if 
needed. You can manually type in the references with correct 
syntax or click the Ellipsis button to use the Attribute Browser. 

6 Click OK. The new symbol appears in the HMI window.

Creating an ArchestrA Object Instance from an 
ArchestrA SmartSymbol Instance

You can create a new ArchestrA object instance from an existing 
ArchestrA SmartSymbol instance. By doing this, you do not need to 
switch between WindowMaker and the IDE. 
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To create a new ArchestrA object instance 

1 In WindowMaker, open the window in which the SmartSymbol 
instance is located. 

2 Double-click the SmartSymbol instance in the application window. 
The SmartSymbol Properties dialog box appears.

3 In the ArchestrA Instance box, type a valid name for the new 
Automation object.

Note:  If this is the first time you specify an object, you are prompted 
to log in. Provide a valid user name, password, and domain name. If 
the Application Server security is set to a mode other than None, a 
domain name is required only for OS User or OS Group Based security.

4 Click New. When the message appears prompting you to select a 
valid Galaxy in which to create the new object, click OK. The 
Galaxy Configuration dialog box appears. 

5 Specify the Galaxy. Do the following:

a In the GR Node Name box, type the name of the computer that 
the Galaxy is running on.

b In the Galaxy Name list, click the Galaxy.



Creating an ArchestrA Object Instance from an ArchestrA SmartSymbol Instance21

InTouch HMI SmartSymbols Guide

c Click OK. The ArchestrA object instance is created and the 
instance references point to the new instance.

d Click OK again to close the Create Instance dialog box.

6 Click OK to close the SmartSymbol Properties dialog box. The new 
SmartSymbol instance appears in the application window.
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Chapter 3

Managing SmartSymbols

Using the SmartSymbol Manager, you can import and export 
SmartSymbols among multiple InTouch applications and across 
different physical systems. Exporting and importing SmartSymbols is 
the best way to move SmartSymbols between InTouch applications.

You can also import windows with SmartSymbols and the graphics 
will be imported—but not the template information—resulting in 
orphaned instances of SmartSymbols. For more information, see 
"Recovering SmartSymbols" on page 30. 

With the SmartSymbol Manager, you can rename, duplicate, delete, 
and save SmartSymbol templates.

Application 1 Application 2

export import

.www file
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Importing SmartSymbols 
You can import SmartSymbols from other InTouch applications into 
your application’s SmartSymbol library. Importing symbols from other 
applications allows you to reuse symbols instead of creating those 
symbols again. 

To import SmartSymbols into the SmartSymbol library 

1 Close all application windows.

2 On the Special menu, point to SmartSymbol, and click Manage 
SmartSymbol. The InTouch SmartSymbol - Management Mode 
window appears.

3 On the File menu, click Import. The Import Symbol dialog box 
appears.

4 Browse for the file that contains the SmartSymbols to import. 
Symbol export files have a .www file extension.
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5 Select the file, and click OK. The SmartSymbols in that file appear 
in the SmartSymbol Management Mode window.

If there is a name conflict, the Import Preferences dialog box 
appears.

6 Do one or more of the following: 

• To skip the import of this symbol, click Skip. If you are 
importing multiple symbols, the rest of the symbols are 
imported. 

• To overwrite the existing symbol with the new one, click 
Overwrite. 

• To rename the new symbol with an unused name, click 
Rename imported symbol. In the Append to symbol name 
box, type the name. 

7 Do one of the following: 

• Click OK to apply the selected option to the SmartSymbol.

• If you clicked Rename imported symbol, click All to apply the 
text in the Append to symbol name box to all SmartSymbols 
with name conflicts in the package file.
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The imported SmartSymbol(s) appear in the InTouch 
SmartSymbol Management Mode window.
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Exporting SmartSymbols 
After you create or import SmartSymbols in your application 
SmartSymbol library, you can export one or more SmartSymbol 
templates to other InTouch applications. Exporting SmartSymbol 
templates is the recommended way to move SmartSymbols between 
InTouch applications.

To export a SmartSymbol 

1 On the Special menu, point to SmartSymbol, and click Manage 
SmartSymbol. The InTouch SmartSymbol - Management Mode 
window appears.

2 From the list of SmartSymbols and folders, select the 
SmartSymbol(s) or folder(s) that you want to export. 

3 On the File menu, click Export. The Export Symbol dialog box 
appears.

4 Browse to the folder to export the symbol to.

5 Type in a file name, with a .www extension, and click Save. The 
SmartSymbol(s) and/or folder(s) is(are) exported to the folder you 
specified. 
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Renaming SmartSymbol Templates
Using the SmartSymbol Manager, you can rename SmartSymbol 
templates. Renaming a SmartSymbol template has no impact on any 
SmartSymbol instances. 

To rename a SmartSymbol template

1 In the SmartSymbol Manager, select the SmartSymbol template 
you want to rename.

2 On the Edit menu, click Rename. 

3 Type in a new name for the symbol and then press Enter. The 
SmartSymbol template appears with the new name. 

Duplicating SmartSymbol Templates
After you create a SmartSymbol template, you can create a copy of it. 
For example, you can duplicate a template and modify and edit it to be 
a new template with similar features. 

For more information on editing SmartSymbol templates, see Editing 
SmartSymbols.

To duplicate a SmartSymbol template

1 In the SmartSymbol Manager, click the SmartSymbol that you 
want to duplicate. 

2 On the Edit menu, click Copy. 

3 Click the folder for the new SmartSymbol.

4 On the Edit menu, click Paste. The new SmartSymbol appears. If 
placed in the same folder as the original, the new SmartSymbol is 
named Copy of <original name>. 
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Deleting SmartSymbol Templates
If you delete a SmartSymbol template, you can no longer open, edit, or 
view the properties of SmartSymbol instances based on the template. 
The run time state of those SmartSymbol instances is not affected by 
the deletion. 

You can recover a deleted SmartSymbol from its instance. For more 
information, see "Recovering SmartSymbols" on page 30. 

To delete a SmartSymbol template

1 In the SmartSymbol Manager, select the SmartSymbol to delete.

2 On the File menu, click Delete. When the message appears, click 
Yes. The SmartSymbol template is deleted from the SmartSymbol 
library. All instances of this SmartSymbol become orphaned. 

Saving SmartSymbols in a Folder Hierarchy
SmartSymbols are stored in the SmartSymbol library in a standard 
hierarchical folder structure. You can see two standard folders are 
included to simplify the organization of SmartSymbols in the 
SmartSymbol library:

• A top-level folder for ArchestrA SmartSymbol templates

• A top-level folder for InTouch SmartSymbol templates 

You can create sub-folders for templates using the SmartSymbol 
Manager. Store ArchestrA SmartSymbol templates in the template 
folder with which they should be associated with when they are 
created. For example, if you create a SmartSymbol to use with $Valve 
objects, store the symbol template in the "$Valve" template folder.

You cannot drag ArchestrA SmartSymbols into an InTouch Symbols 
folder, and you cannot drag InTouch SmartSymbols into an ArchestrA 
Symbols folder.

To move a SmartSymbol to a different folder

1 Select the SmartSymbol you want to move. 

2 Drag the SmartSymbol into the new folder. 
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Support for SmartSymbols and Language 
Switching

Language switching works for SmartSymbols if the SmartSymbol 
template exists in the application.

If a SmartSymbol contains translatable text objects, when you export 
the dictionary a separate XML is generated, for example 
SSD_<SymbolName>_<LangID>_<ID>.xml. This XML file contains all 
translatable strings contained in the SmartSymbol. You can open it in 
Excel and translate the text strings like you would for any InTouch 
application.

When you import the translation for an InTouch application, the 
translations for each SmartSymbol are imported as well.

When you switch languages in WindowViewer, any SmartSymbols 
containing translatable strings that are translated in this way appear 
translated.

When exporting SmartSymbols that have dictionary files, the 
dictionary files are exported along with the .www file. For more 
information about language switching, see Switching a Language at 

Run Time in the InTouch® HMI Application Management and 
Extension Guide.

Recovering SmartSymbols
When you delete a SmartSymbol template from the library, all 
instances of that SmartSymbol are considered “orphaned” instances. 
You can recover a deleted SmartSymbol from an orphaned instance. If 
an orphaned instance does not exist in an application window, you 
cannot recover the SmartSymbol.

If you try to open the properties of an instance after the SmartSymbol 
template is deleted, a warning message appears telling you that the 
SmartSymbol no longer exists in the library. 

You can also have orphaned instances if you import a window 
containing SmartSymbols. You must recover the SmartSymbol from 
the orphaned instance and then rename the SmartSymbol.
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To recover a deleted SmartSymbol 

1 Click an orphaned instance of the deleted SmartSymbol in an 
InTouch HMI application window. 

2 On the Special menu, point to SmartSymbol and click Recover 
SmartSymbol. The SmartSymbol appears in the SmartSymbol 
Management Mode window, with a name of New Symbol. 

3 Rename the SmartSymbol as appropriate. 
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Chapter 4

Editing SmartSymbols

After you create a SmartSymbol, you can edit it by changing and 
modifying the template or an instance of the SmartSymbol.

Changing SmartSymbol Templates
To edit a SmartSymbol, break the cell and then use the drawing tools 
to make changes. You can also change the animation that is associated 
with the SmartSymbol. Template changes affect all instances of the 
SmartSymbol. 

Note:  Edit SmartSymbols in a temporary window rather than in an 
application window. 

SmartSymbol Instances

changes

SmartSymbol Template
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To edit an existing SmartSymbol template

1 On the Special menu, point to SmartSymbol and click Start 
SmartSymbol Edit. 

2 Click in the window where you will edit the SmartSymbol. The 
InTouch SmartSymbol - Select Mode window appears.

3 Select a SmartSymbol to edit and click OK. An instance of the 
SmartSymbol is placed in the application window. 

4 On the Arrange menu, click Break Cell. The symbol is broken into 
its component elements.

5 You can now edit one or more elements.

Note:  If you add elements to a cell that is part of a SmartSymbol, this 
can result in a spatially larger cell. When you propagate the changes to 
the SmartSymbol instances, you can select whether or not to propagate 
the size change. 

6 When you are done editing, select all elements of the symbol. On 
the Arrange menu, click Make Cell.
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7 On the Special menu, click SmartSymbol, and then click End 
Symbol Edit. The SmartSymbol Update Confirmation dialog box 
appears.

8 If the size of the edited SmartSymbol changed, you can configure 
the size propagation. Do one of the following:

• To not affect the size of existing SmartSymbol instances, clear 
the Update Size of Symbols in Application check box.

• To propagate the change in the size of the template to the 
SmartSymbol instances, select the Update Size of Symbols in 
Application check box, and in the Anchor Point list, click which 
part of a SmartSymbol instance is to be "anchored" to the 
screen when the resizing is done. 

9 Do one of the following: 

• To apply the changes you made, click Commit Edit. The 
SmartSymbol Manager updates the SmartSymbol template 
and all instances. 

• To continue editing the SmartSymbol, click Return to Edit. The 
application window reappears for further editing. 

Changing SmartSymbol Instances
You can change any references and static text in a SmartSymbol 
instance. You can search and replace the static text in the instance. 
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Selecting a Different Reference for a 
SmartSymbol Instance

After you place a SmartSymbol in a window as an instance, you can 
change its references to point to something different, such as another 
object or a different tag. The SmartSymbol template is not affected.

At run time, you can change the tags a SmartSymbol instance 
references by using the IOSetRemoteReferences() script function. For 
more information, see Redirecting Remote References During Run 

Time in the InTouch® HMI Data Management Guide.

To edit references in a SmartSymbol instance 

1 Double-click the SmartSymbol instance. The SmartSymbol 
Properties window appears.

2 Do any of the following:

• Click the Ellipsis button next to Symbol Template to select a 
new SmartSymbol template.

• Click the Ellipsis button next to the ArchestrA Instance text 
box to browse for an ArchestrA object instance. 

3 Select a different object instance to map to the SmartSymbol and 
click OK. 
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Manually Editing Text and References of a 
SmartSymbol Instance

After you create a SmartSymbol instance in an application window, 
you can change the static text in the instance. 

To change the static text in a SmartSymbol instance

1 Double-click the SmartSymbol instance. The SmartSymbol 
Properties window appears.

2 In the Instance References column, click in the text box and 
modify the text.

3 Click OK. 
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Replacing SmartSymbol Instance Tagnames and 
Text Strings

If several references and text strings of a SmartSymbol instance 
require the same change, you can use the replace feature.

To replace SmartSymbol instance references

1 Double-click the SmartSymbol instance. The SmartSymbol 
Properties window appears.

2 Click Replace. The Replace dialog box appears.

3 Configure the replacement text strings. Do the following:

a In the Find what box, type the text you want to replace. Select 
the Match case check box make the search case-sensitive.

b In the Replace with box, type the replacement text. The 
replacement text is always used exactly as typed. 

4 Do one of the following:

• To replace all text, click Replace All. 

• To find and replace the text one instance at a time, click Find 
Next and click Replace to replace that one instance. 



Changing SmartSymbol Instances39

InTouch HMI SmartSymbols Guide

5 Click OK. The SmartSymbol instance in the application window 
appears with the changed tags and text strings. 
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