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= Note

This document assumes that you are familiar with the Microsoft Windows NT/2000/XP envi-
ronment, including how to move files, manage system preferences, establish network con-
nections, and install new software. If you do not have this familiarity, then please consult
the Windows Help feature as you work through this document.
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Introduction

This document describes how to configure InduSoft Web Studio (IWS) and Beckhoff’'s TwinCAT con-
trol software to run together on various Microsoft Windows-based devices, as well as how to estab-
lish communication between those devices on an Ethernet network.

The following diagram shows a mixed device network using both InduSoft and Beckhoff software
components:

Windows NT/2000/XP or XPe Beckhoff CX Series, Windows XPe
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Figure 1. Mixed Device Network Using IWS and Beckhoff Components

Each device in the diagram shows a unique combination of operating system, InduSoft software
components, and Beckhoff software components.

The primary component in this system is Beckhoff’'s Automation Device Specification (ADS) library,
which makes a compatible workstation or industrial PC running Windows NT/2000/XP, an embed-
ded PC running Windows XPe, or a Windows CE-based device into a TwinCAT-compliant node. This
library establishes a data exchange protocol that works over standard Ethernet TCP/IP, so that any
node with the library installed can communicate directly with your TwinCAT control application,

Page 2/60

InduSoft Ltd.



DRAFT — 8 September 2006 Getting Started with IWS and TwinCAT

wherever it may be hosted. The ADS library is included in the full TwinCAT software, but it is also
available as a free, separate package from Beckhoff.

InduSoft provides a TWCAT communication driver for IWS and CEView. The TWCAT driver, when
properly selected configured in your IWS application project, communicates with TwinCAT through
the ADS library. In this way, IWS is fully compatible with TwinCAT.

The rest of this document will explain...

= How to choose, acquire and install the necessary software components for each of these de-
vice configurations;

* How to use the utilities provided with the ADS library to establish communication between
devices; and

= How to build a sample application in IWS that uses the TWCAT driver and the ADS library to
communicate with TwinCAT.

Quickstart for Beckhoff CX1020 or CX1000

This document covers most conceivable options and configurations for working with IWS and Twin-
CAT, and as such it is very detailed and somewhat spread out. However, the majority of users will
probably need to know only how to set up a Beckhoff CX1020 or CX1000 running Windows CE.

Beckhoff CX Series, Windows CE

1 1
1 1
1 1
1 1
| |
! TwinCAT InduSoft '
' runtime CEView '
! (preinstalled) '
1 1
| ADS TWCAT
| Library driver :
i :
1 1
1 1
1 1

______________________________________

Figure 2. Typical Configuration for Majority of Users
If this is your configuration, then you can use the following quickstart guide to jump directly to the
relevant sections in this document:

1) Download and run the CEView custom installer (i.e., the .caB file) for Beckhoff CX Series
devices — starting on page 12.

2) Establish a link between IWS on your workstation and CEView on the device, and then up-
date CEView to the latest version — starting on page 14.

3) License CEView on the device — starting on page 15.

4) Select the TWCAT driver and add it to your IWS application project — starting on page 39.
5) Build the driver worksheet — starting on page 46.

6) Download the finished IWS application to the device — starting on page 53.

= Note

This quickstart guide assumes that you are already familiar with both InduSoft Web Studio
and the TwinCAT programming software. It only describes how to set up a Beckhoff CX Se-
ries device in an existing production environment. If you need more thorough instructions,
then please review this entire document.
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Installing the Software Components

This section explains how to choose, acquire and install the necessary IWS and Beckhoff software
components for several different platforms. These platforms include:

= A workstation or industrial PC running Windows NT/2000/XP;

= An embedded PC running Windows XPe;

= A Beckhoff PLC, model CX1020 or CX1000; and

* A Windows CE-based device (other than Beckhoff's CX Series).
Each configuration is described in detail in this section, but first...

Getting the Software

Before proceeding with installation on any device, make sure that you have all of the correct soft-
ware (as well as the latest versions thereof) on hand.

IWS, CEView, and the TWCAT Driver

As of this document revision, the latest version of IWS is 6.1+SP1. You can order it on CD from
your InduSoft sales representative, or you can download it from InduSoft's Web site at
www.indusoft.com. The full version of IWS can be installed directly on a desktop PC running Win-
dows NT/2000/XP or on an embedded PC running Windows XPe.

Included in IWS are all of the files required to install CEView — the IWS runtime engine for Win-
dows CE-based devices — on any of the following embedded PC (a.k.a. mobile) processor types:
ARM V4, ARM V41, ARM V4T, MIPS II, MIPS II FP, MIPS IV, MIPS IV FP, SH3, SH4, and x86.

= Note

Although the full version of IWS can be downloaded from InduSoft's Web site, you must
have a valid license to run it beyond the free evaluation period. Please contact your Indu-
Soft sales representative for licensing options, and consult the InduSoft Web Studio User
Guide for more information about applying the license.

Also included in IWS are all of the communication drivers available at the time of release. However,
these drivers are always under development, so a newer version of the TWCAT driver may be
available. You can download the latest TWCAT driver from InduSoft's up-to-date driver list at
www.indusoft.com.br/download/drivers/.

TwinCAT and the ADS Communication Library

You can order the TwinCAT development software on CD from your Beckhoff sales representative,
or you can download it from Beckhoff's Web site at www.beckhoff.com. TwinCAT can be installed
on a wide variety of platforms including traditional PCs, embedded PCs, and Beckhoff’'s own CX Se-
ries of PLCs. However, for the purposes of this document, only installation on traditional PCs will be
discussed. For more information about installing TwinCAT on other platforms, please consult Beck-
hoff’'s documentation.

= Note

Although the full version of TwinCAT can be downloaded from Beckhoff's Web site, you must
have a valid license to run it beyond the free evaluation period. Please contact your Beck-
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hoff sales representative for licensing options, and consult the TwinCAT documentation for
more information about applying the license.

Keep in mind that you may not need to acquire the full version of TwinCAT for your installation; the
TwinCAT runtime engine comes preinstalled on most Beckhoff devices, and on other devices you
may only need to install the ADS library to enable communication.

The ADS communication library is freely available from Beckhoff and can be acquired in several dif-
ferent ways:

= If you have already installed TwinCAT on a traditional PC, then the ADS library files are
available on that PC in the \TwinCAT\ADS Api directory;

= The ADS library can be installed from the TwinCAT Supplement CD that comes with the
TwinCAT Installation CD; or

= The ADS library is available as a free, standalone download from Beckhoff’'s Web site at
www.beckhoff.com. The full name of the download is TwinCAT_ADS_Communication_Library, and it
is listed in the TwinCAT Supplement section of the site.

The ADS communication library can be installed on a traditional PC running Windows NT/2000/XP,
on an embedded PC running Windows XPe, or on a Windows CE device using any of the following
processor types: ARM, 1586, MIPS, SH3, SH4, StrongARM HPC, StrongARM PPC, StrongARM 1100,
and StrongARM V41.

Windows CE Utilities

If you will be working with Windows CE — either on a Beckhoff PLC or on some other Windows CE-
based device — then you should consider having these two utilities installed on your workstation:

= First, you can use Microsoft ActiveSync to easily transfer files between your workstation
and a connected Windows CE-based device. ActiveSync communicates with the device via
serial or USB, and when the device is properly connected, it appears on your workstation
(under My Computer) as a removable drive.

Get Connected

Checking COM Ports
Please wait while Setup lozates your mobile device.

Progress

Looking for a mobile device...
Checking on COM Port 1
Checking USE

| | Cancel | |

Figure 3: Using Microsoft ActiveSync to Connect to a Windows CE-based Device

ActiveSync can be downloaded for free from Microsoft’'s Web site at:
http://www.microsoft.com/windowsmobile/addons/

InduSoft Ltd. Page 5/60



Getting Started with IWS and TwinCAT DRAFT — 8 September 2006

= Second, you can use Remote Display Control for Windows CE (also known as
CERHOST .exe) to open a console window on your workstation that shows the desktop of a
connected Windows CE-based device. Through this console window, you can fully operate a
“headless” device — that is, a device without its own display, keyboard or mouse — using
only your workstation.

Remote Display Control communicates with the device via Ethernet TCP/IP, similar to both
TwinCAT and IWS. However, you must know the hostname or IP address of the device in
order to connect to it, so be sure to get this information beforehand.

M Remote Display Contr... [ |[B))
%=1 Zoom Tools Help

Exit

Connect
Hostname: [cx_o01122
oK l Cancel I

Figure 4: Using Remote Display Control to Connect to a Windows CE-based Device
Microsoft includes Remote Display Control as part of their Windows Mobile developer toolkit,
but Beckhoff also offers the utility on their Web site at:
http://ftp.beckhoff.de/Software/embPC-Control/CE/Tools/RemoteDisplay/

For more information about using Microsoft ActiveSync or Remote Display Control, please consult
Microsoft’s documentation.

= Note

The addresses given above are accurate at the time of this writing, but they may change in
the future as Microsoft and/or Beckhoff update their Web sites.
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Installing on a Workstation or Industrial PC — Windows NT/2000/XP

When installing on a workstation or industrial PC running Windows NT/2000/XP, there are typically
only two possible configurations. (See page 2 for more information about these configurations and
their places in a mixed network.) Each configuration is described below.

Full Version of IWS + Full Version of TWinCAT
To install both IWS and TwinCAT on the same PC:
1) Install and license the full IWS development software, as described in its documentation.
2) Download the latest TWCAT driver from InduSoft's Web site (see page 4), unzip it, and
copy all of its files to the \DRV directory of your IWS installation. For example...

C:\Program Files\Indusoft Web Studio v6.1\DRV\
3) Install and license the full TwinCAT development software, as described in its own documen-
tation.

Installing TwinCAT will automatically enable communication between the PC and other TwinCAT-
compliant devices, so you do not need to do anything else to configure IWS.

Full Version of IWS + the ADS Communication Library
To install IWS and the ADS library on the same PC:
1) Install and license the full IWS development software, as described in its documentation.
2) Download the latest TWCAT driver from InduSoft's Web site (see page 4), unzip it, and copy
all of its files to the \DRV directory of your IWS installation. For example...

C:\Program Files\Indusoft Web Studio v6.1\DRV\

3) Acquire the ADS communication library (see page 4), and locate the following files therein:
= \TcAdsD1l1l\AdsD1l1l.d1ll
= \TcAdsD1l1l\TcAdsDl1l.d1ll
= \TcAdsD1l1l\TcAdsTest.exe
= \TcAdsDll\TcAmsRemoteMgr.exe

4) Copy all four files to the \BIN directory of your IWS installation. For example...

C:\Program Files\Indusoft Web Studio v6.1\BIN\

With the ADS library and the latest TWCAT driver both installed, IWS is ready to communicate with
TwinCAT running on a remote device. Unless you are performing additional installations on other
devices, you may proceed to the next section, “Establishing Communication Between TwinCAT Sta-
tions,” on page 25.
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Installing on an Embedded PC — Windows XPe

Although it is technically an embedded PC — that is, a slimmed down operating system running on
solid-state hardware — a system running Windows XP Embedded (XPe) provides the same basic
compatibility as a workstation or industrial PC running Windows XP. As such, you can configure this
Windows XPe-based device much like the workstation described in the previous section, with full
versions of both IWS and TwinCAT or with the full version of IWS and the ADS library.

The biggest difference between a traditional workstation and an embedded PC — at least for the
purposes of this document — is that the embedded PC does not have its own CD drive. (If it did,
then it wouldn’t be solid-state.) Without a CD drive, it is not possible to install software directly
from CD to the device. Therefore, you must find another way to install the software.

IMPORTANT! Do Not Install Supplemental Files!

Regardless of how you install IWS
on your embedded PC, you are I|ke|y ct the features pou do not want ta install
to use it only as a runtime engine et

and not as a development station.
Therefore, you should not install
any of the supplemental files (i.e., *-[] Dema Files

files other than the core Program [Lirary Files
Files); when you run the IWS instal- mmunication Ditvers Files
lation wizard, be sure to deselect
these files as shown at right. Skip-
ping these files will reduce the size
of the IWS installation by over 260
MB, which is important on an em-
bedded PC where persistent (non-
volatile) memory is extremely lim-
ited.

Don’t worry about not installing the
communication drivers. You only
need the TWCAT driver to communi- Deselecting the Supplemental Files in the Installation Wizard

cate with other TwinCAT stations,

and you can always download the latest version of that driver from InduSoft's Web site. For more
information, see pages 4 and 7.

Installing from External CD

You can attach an external (or “backpack”) CD drive to your embedded PC, typically using a USB
2.0 connection. The drive should mount normally under Windows XPe. From there — assuming you
have installation CDs for IWS and TwinCAT — you can proceed to install the software on your em-
bedded PC just as if it’s a traditional workstation, as described in the previous section.

Installing from Internet Download

If your embedded PC is connected to the Internet, then you can directly download the IWS, Twin-
CAT and/or ADS library installers from their respective Web sites. And again, you can proceed from
there to install the software on your system as described in the previous section.

However, you may not want to do this because merely downloading the installers requires several
hundred megabytes, and an embedded PC’s persistent (non-volatile) memory is extremely limited.
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It's possible that there simply isn’t enough space to both download the installers and install the
software. It all depends on how much non-volatile memory you have available.

Furthermore, for the sake of network maintenance and security, embedded PCs on the plant floor
often are not connected to the Internet. Yet, they usually are connected to the internal network so
you may be able to run the installers from another PC.

Installing from Another PC

If your embedded PC is connected to the internal network, then you may be able to run the IWS,
TwinCAT and/or ADS library installers from another PC on the network. To do this, you must first
locate a workstation that is connected to both the Internet and the building network, and then you
must download the installers to that workstation.

Once you have the installers, you can upload them from the workstation to a common file server
(a.k.a. network drive) or you can share them directly from that workstation. Either way, you can
then go to the embedded PC, map the appropriate network drive, and run the installers. For more
information on sharing files and mapping network drives, please consult the Windows help system.

Installing from CompactFlash

CompactFlash (CF) memory is a popular form of solid-state, non-volatile file storage, and most
embedded PCs are designed with not only internal flash memory but also CF memory card readers.
You can copy the IWS, TwinCAT and/or ADS library installers from your workstation onto a CF card,
and then insert that card into your embedded PC. The card should appear under My Computer as a
removable drive, and once it does, you can then run the installers saved on it.

Installing from USB Drive

Windows XPe provides full support for USB, so you should be able to use a USB flash drive (also
known as a “thumb drive”) to transfer files in the same way that you would use a CF memory card,
as described above. The only limitation is whether your embedded PC has an open USB port.
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Installing on a Beckhoff PLC (CX1020 or CX1000)

Beckhoff offers the CX Series of embedded PCs that are packaged with all of the necessary com-
munication and I/O options to make them fully functional PLCs. The CX Series includes:

* The Beckhoff CX1020 with an Intel® Celeron® M processor up to 1.0 GHz; and
* The Beckhoff CX1000 with an AMD® Geode processor up to 266 MHz.

The CX1020 can be configured with either Windows XPe or Windows CE. The CX1000 can only be
configured with Windows CE.

Both models come with the TwinCAT runtime software preinstalled, so you only need install the In-
duSoft software component that is appropriate to the operating system: the full version of IWS on
Windows XPe, or the CEView runtime engine on Windows CE.

Installing IWS on a Beckhoff CX1020 Running Windows XPe

For the purposes of this document, a Beckhoff PLC running Windows XPe is just like any other em-
bedded PC running that operating system. Therefore, to install the full version of IWS, follow the
instructions already provided in “Installing on an Embedded PC — Windows XP” on page 8.

Please consult Beckhoff's documentation for more information about the device’s communication
options and OS configuration.

Installing CEView on a Beckhoff CX1020 or CX1000 Running Windows CE

Installing new software on a Windows CE-based device can be tricky because the default system
preferences and directory structure vary greatly from manufacturer to manufacturer and from
model to model. This is because such devices have extremely specific hardware configurations and
limited system resources. When the manufacturer develops the OS load for these devices, it selects
only the minimum options required to drive the hardware.

The same is true for Beckhoff’'s CX Series, but to make things easier for users who want to run
TwinCAT and InduSoft together on the same device, Beckhoff has also developed a custom installer
that automatically installs InduSoft's CEView in the correct directory and makes the necessary
changes to the system registry.

= Note

This custom installer is only available for Beckhoff CX Series devices running Windows CE.
There is no equivalent for CX Series devices running Windows XPe; see “Installing IWS on a
Beckhoff CX1020 Running Windows XPe” above.

CX Series devices can be ordered from Beckhoff with this custom installer already applied; the op-
tion is listed in Beckhoff's catalog as “"CX1800-0005 InduSoft HMI CE Runtime.” The installer can
also be downloaded from Beckhoff’'s Web site and run by the user, in case a device is ordered with-
out the InduSoft option.

InduSoft and Beckhoff work together to try to make sure this installer always includes the latest
version of CEView. It is important to have the latest version installed on your CX Series device, in
order to correctly run your IWS applications. Working with different versions of IWS and CEView
may result in serious errors.

Unfortunately, it’s still possible for InduSoft and Beckhoff to fall out of sync, so that even a freshly
downloaded installer may include an old version of CEView. As such, when you receive a new de-
vice with the InduSoft option or when you run the installer yourself, you should still use the Execu-
tion Environment tool in IWS to update CEView on the device.
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In general, the rest of this section describes the following procedure:

1) Check to see if CEView is already installed on the device — that is, check to see if the
custom installer has already been applied.

2) If CEView is not installed, then download the custom installer and run it.

3) Use the Execution Environment tool in IWS to connect to the device, and then update CE-
View to match IWS.

4) Entire your runtime license for CEView.

You may wonder why you should download and run the custom installer if there's a chance it will
install an old version of CEView that needs to be updated anyhow. Why not install CEView from
scratch using the Execution Environment tool in IWS? Well, because the installer automatically
makes changes to the device’s directory structure and system registry that are more difficult to
make manually. In the end, it's simply easier to run the installer and then update.

Before you proceed, make sure that you meet the following prerequisites:
* You must have the full IWS development software installed on your workstation;

* Your CX Series device should be connected to your workstation by serial or Ethernet. If it is
connected by Ethernet, then it should be assigned a valid IP address;

* You must have a way to control the device, either through a console window (see page 6) or
by physically attaching a display and a mouse; and

* You must have a way to transfer files from your workstation to the device, either through
Microsoft ActiveSync (see page 5), by manually copying the files onto the device’s Compact
Flash memory card, or by copying across the network.

For help with meeting these prerequisites, please consult Microsoft’'s documentation for Windows
CE and Beckhoff's documentation for the CX Series device.

Checking for CEView and Remote Agent

Now that you're ready, check to see if the custom installer has already been run on your CX Series
device. You can do this by looking for the \Hard Disk\InduSoft directory which contains the CE-
View files.

Also, if the installer has been run on the device, then it should already be configured to automati-
cally start Remote Agent on boot. Try rebooting the device — that is, tap the Start button to open
the Start menu and then select Suspend. When the device boots up again, the Remote Agent utility
should appear:

Remote Agent (v4.0)

Caonneckion status:
[Mak connected to remate client

Log:

Device connection via E =
Metwork (TCP/IP) —
Local IP; 172.16.3.91 | Exit

Figure 5. Remote Agent Utility Running in Windows CE
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= Note

Remote Agent is a communications utility included in the CEView installation. It enables
communication between IWS on your workstation and CEView on the device. In this way, it
serves much the same purpose that the ADS library serves in TwinCAT.

If the CEView files are present and Remote Agent starts automatically on boot, then skip to
“Updating CEView to the Latest Version” on page 14. If not, then proceed to “Downloading and
Running the Custom Installer” below.

Downloading and Running the Custom Installer

To download and run the installer yourself:

1) Acquire the "CX1800-0005 InduSoft HMI CE Runtime” installer. The actual name of the in-
staller file is:

CX1800-0005_HMI_InduSoft.I586.CAB

This file is included on the TwinCAT Supplement CD, but it can also be downloaded for free
from Beckhoff's Web site at:

http://www.beckhoff.com/english/default.htm?download/cx _ce hmi.htm

= Note

The address given above is correct at the time of this writing, but it may become in-
valid as Beckhoff updates their Web site. You can also use the site’s navigation tree
to find the Web page; it should be listed under Download > Software > Embedded PC.

2) Copy the installer file to the device. You should save the file in the device’s \Hard
Disk\System directory.

3) Locate the installer file on the device and double-tap its icon. This will run the installer.

4) Follow the on-screen installation instructions. When the installer prompts you to confirm the
creation of the \Hard Disk\InduSoft directory, tap the OK button.

Install BECKHOFF CX1000-HMI-Indusoft 1| 5| [; @ [x]
2] \Hard Disk\,

' Docurnents and Settings O TwinCAT

JFTP L WA

— public i,_-”;_‘jEleetthen's Syrmphory
CRAM =] BLDT 116.ROM

) System %CKIBDD-DDDS_HMI_IHEI

/] | a
ame: |InduSth Type: | _I

Figure 6. Creating the InduSoft Directory
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The CEView files are installed in the \Hard Disk\InduSoft directory, and the system regis-
try is updated.

Installing BECKHOFF CX1000-HMI-InduSoft

Copying files...

YHard DisklInduSoft\CeServer.exe

[ ]

Cancel

Figure 7. Installing Files in the InduSoft Directory

5) When the installation is finished, reboot the device by selecting Start » Suspend. This will save
the updated directory and registry information to the persistent (non-volatile) memory.

After the reboot, the Remote Agent utility should start automatically.

Remote Agent (v4.0)

Caonneckion status:
[Mak connected to remate client

Log:

B

o o vi : i
pevce omtonis. [sewp | sor
Local IP: 172.16.3.91 | Exit
Figure 8. Remote Agent Utility Running in Windows CE
6) Tap Setup to open the Setup dialog:

setep x|

Device Connection
¢ Serial Port [COM1 ™ w|  Advanced..
" TCP/AP '4'

-

™ Run CE¥iew on startup

Users... | Ok | Cancel |

Figure 9. Setup Dialog in Remote Agent

Configure the Device Connection settings as needed, depending on how you’ve connected
the device to your workstation. For complete instructions, please consult the InduSoft Web
Studio User Guide. You do not need to enter a license at this time.

7) Tap OK to close the Setup dialog.
Remote Agent is now ready to receive communication from IWS running on your workstation.
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Updating CEView to the Latest Version

Assuming you have already installed the full, latest version of IWS and the latest TWCAT driver
(see “Getting the Software” on page 4), you can use the following instructions to update CEView on
your CX Series device:

1) On your workstation, start Indusoft Web Studio.

2)

3)

4)

5)

6)
7)

From the main menu bar, select Tools » Execution Environment. The Execution Environment dia-
log will be displayed:

Execution Environment

Target | Application | Import | CE License

Target Station

@ Local Status:
) Network IP;

= Platform:
() Serial Port:

O Microsoft ActiveSync

Close

Figure 10. Execution Environment Dialog

Configure the Target Station settings as needed, depending on how you’ve connected the
device to your workstation. For complete instructions, please consult the InduSoft Web Stu-
dio User Guide.

Click Connect to establish communication with the device.

If communication is successfully established, then the Status and Platform fields will be up-
dated to reflect the connected device. Also, the Remote Agent utility on the device will show
that it has successfully connected back to IWS.

Make sure the Only newer files option (checkbox) is enabled, and then click Install system files... to
update the CEView files on the device.

When the installation is completed, click Close to close the Execution Environment dialog.

Reboot the device once more by selecting Start » Suspend. This will save the updated files to
the device’s persistent (non-volatile) memory.

You should now have the TwinCAT runtime software, the Remote Agent utility, and the updated
CEView files all installed on your CX Series device.
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Licensing CEView

You must have a valid license to run CEView beyond the free evaluation period. You can obtain this
license by contacting your InduSoft sales representative and providing the device’s “site code.” The
representative will use this site code to generate a corresponding license code, which you can then
apply to the device.

The actual licensing can be done in either of two ways: via the Execution Environment tool in IWS,
or directly at the device. If you've already used the Execution Environment tool to connect to the
device and update the CEView software (see the previous page), then it's very easy to also license
the software.

When you are ready, proceed with the following instructions:
1) In the Execution Environment dialog, select the CE License tab:

Execution Environment

| Target | Application | Import | CE License

Lizensze Settings
Product Type: | CEYiew PRO

Wergiarn: EE! Murnber of "Web Thin Clients: .E
Lizenze Codes
Site Code: | 7936 CFAR BC23 4549 1481 3450 BB21 2298 AA |
Site Keyw |

Cloze

Figure 11: CE License Tab in the Execution Environment Dialog

2) Copy the code given in the Site Code field and send it to your InduSoft sales representative.
Your representative will return a license key that corresponds to the site code.

= Note

The site code shown above is given only as an example. Your device’s actual site
code is generated when CEView is installed, and it is unique to your device.

3) Enter the license key in the Site Key field and click Send.

If the site key is accepted (validated), then a confirmation message will be displayed. If the
site key is not accepted, verify that you have entered it correctly and try again. If it is still
not accepted, then contact your InduSoft sales representative for assistance.
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If for whatever reason you cannot connect to the device via the Execution Environment tool in IWS,
you can still apply a license directly on the device itself:

1) On your CX Series device, in the Remote Agent utility, tap Setup to open the Setup dialog:

setup x|

Device Connection
¢ Serial Port Icgm vl Advanced... I

" TCPAP
" Infra Red

™ Run CEView on startup

Users... | Ok Cancel

Figure 12. Setup Dialog in Remote Agent

2) Tap License to open the License dialog:

x

Current License
Product Type:

|CEView Standard
Version [X.Y]):  Web Thin Clients:

Close |

Figure 13: License Dialog in Remote Agent

3) Tap Change License to open the Change License dialog:

Change License x|

Site Code
|87BB8?8786878F87808788?8A87E

Site Key:

Authorize I

Figure 14: Change License Dialog in Remote Agent

4) Copy the code given in Site Code field and send it to your InduSoft sales representative.
Your representative will return a license key that corresponds to the site code.

= Note

The site code shown above is given only as an example. Your device’s actual site
code is generated when CEView is installed, and it is unique to your device.
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5) Enter the license key in the Site Key field and click Authorize.
If the site key is accepted (validated), then the following message is displayed:

success

Site key accepted.

Figure 15: Site Key Accepted
If the site key is not accepted, verify that you have entered it correctly and try again. If it is
still not accepted, then contact your InduSoft sales representative for assistance.

When CEView is properly installed, updated, licensed, and ready for runtime, you can proceed to
“Establishing Communication Between TwinCAT Stations” on page 25.
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Installing on a Windows CE-based Device

= Note

This section discusses Windows CE-based devices in general. Beckhoff’s CX Series devices
(i.e., the CX1020 and the CX1000) are discussed in the previous section.

Any Windows CE-based device can be made a fully compatible node in your TwinCAT/InduSoft sys-
tem, but it requires a few extra steps because the device does not come with any of the necessary
software preinstalled and there is no custom installer to do it for you.

Since this is not a Beckhoff device, you cannot install the full TwinCAT runtime software. Instead,
you can install the ADS library that enables communication with other TwinCAT nodes. You can
then install InduSoft CEView, which ties into and communicates through the ADS library.

In general, the rest of this section describes the following procedure:
1) Determine the OS version and processor type of your Windows CE-based device.
2) Install the ADS library that is appropriate to the processor type.
3) Install the Remote Agent utility and configure it to start automatically on boot.

4) Use the Execution Environment tool in IWS to establish communication between your work-
station and the device, and then install CEView on the device.

5) Enter your runtime license for CEView.
Before you proceed, make sure that you meet the following prerequisites:
* You must have the full IWS development software installed on your workstation;

* Your Windows CE-based device should be connected to your workstation by serial or
Ethernet. If it is connected by Ethernet, then it should be assigned a valid IP address;

* You must have a way to control the device, either through a console window (see page 6) or
by physically attaching a display and a mouse; and

* You must have a way to transfer files from your workstation to the device, either through
Microsoft ActiveSync (see page 5), by manually copying the files onto the device’s Compact
Flash memory card, or by copying across the network.

For help with meeting these prerequisites, please consult Microsoft’'s documentation for Windows
CE and the manufacturer’s documentation for the device.

Determining Your OS Version and Processor Type

Both CEView and the ADS library come in different “flavors” for the various processor types, so you
must determine the processor type on your Windows CE-based device. You should also note which
specific version of Windows CE your device is running.

To determine OS version and processor type in Windows CE:
1) Tap the Start button to open the Start menu, and then select Settings » Control Panel.
2) In the Control Panel, double-tap the System icon to open the System dialog.

3) In the System dialog, select the General tab. The OS version (e.g., Windows CE 3.x, Windows
CE .NET, Windows CE 5.x) and processor type (e.g., ARM, MIPS, SH3) will be displayed.
Make note of this information.

4) Close the System dialog.
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= Note
“Windows CE .NET” is another name for Windows CE 4.x.

Installing the ADS Library

The ADS communication library for Windows CE is provided as a single cabinet file, as opposed to
the handful of separate files that are provided for Windows NT/2000/XP. A cabinet file (*.caB) is
an automated installer that is specifically written for Windows CE. All you have to do is copy the
cabinet file to the Windows CE device and run it there; it will install its files in the correct places,
edit the system registry (if necessary), and remove itself when it’s done.

To install the ADS library on your Windows CE device:

1) Acquire the ADS communication library as described previously (see page 4), open it on
your workstation, and locate the following file therein:

\TcAdsDl1lCe\setup\TcAdsDl1lCe.<processor type>.CAB

...Wwhere <processor type> is the type of processor that is in your device.

For example:

\TcAdsDl1lCe\setup\TcAdsDl1lCe.MIPS.CAB
Please note that each cabinet file is a complete installer. You will only need one file — the
one that corresponds to your device’s processor type — to install the ADS library.

2) Copy this file to the device’s persistent (non-volatile) file storage. If you don’t know where
this is, then please consult the manufacturer’s documentation.

The directory structures of different Windows CE-based devices can vary greatly, and the
device manufacturer may require that files be stored in a specific directory, so please con-
sult the manufacturer’'s documentation.

3) Go to the Windows CE device, locate the cabinet file there, and double-tap its icon to run it.
4) Follow the on-screen instructions, if any.

5) When the installation is finished, reboot the device to save the new files and settings to per-
sistent (non-volatile) memory.

The ADS library should now be installed on your Windows CE device. You will verify it in the next
section, “Establishing Communication Between TwinCAT Stations,” on page 25.
Installing the Remote Agent Utility
To install Remote Agent on your Windows CE device:
1) On your workstation, locate the following file:

\<IWS directory>\Redist\<0S version>\<processor type>\BIN\CEServer.exe
..where:
— <IWS directory> is the directory where you installed IWS;

— <08 version> is the version of Windows CE running on your device (see note); and

— <processor type> is the processor type that is in your device.
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= Note
For devices running Windows CE 3.x, use the files located in the \Redist\CeView di-
rectory.

For devices running Windows CE 4.x (a.k.a. Windows CE .NET) and Windows CE 5.x,
use the files located in the \Redist\Wince 4.0 directory.

For example, for a device running Windows CE 3.1 on an Intel x86 processor:

\InduSoft Web Studio v6.1\Redist\CeView\x86\BIN\CEServer.exe

For a device running Windows CE 5.0 on an ARM V4 processor:

\InduSoft Web Studio v6.1\Redist\Wince 4.0\Armv4\BIN\CEServer.exe

2) Copy this file to the device’s persistent (non-volatile) file storage.

The directory structures of different Windows CE-based devices can vary greatly, and the
device manufacturer may require that applications be stored in a specific directory, so
please consult the manufacturer’s documentation.

3) You can now run Remote Agent in Windows CE by double-tapping the CEServer.exe icon.
When you run it, the Remote Agent window is displayed:

Remote Agent (v4.0)

Caonneckion status:
[Mak connected to remate client

Log:

=]

o o v z i
pevce omtonis. [sewp | sor
Local IP: 172.16.3.91 | Exit
Figure 16. Remote Agent Running in Windows CE
4) Tap Setup to open the Setup dialog:

setup x|

-Device Connection

* Serial Pottlcgm v || FAdvanced
" TCP/AP “—l

€ InfraRe

™ Bun CEView on startup

Users... Ok Cancel

Figure 17. Setup Dialog in Remote Agent
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Configure the Device Connection settings as needed, depending on how you’ve connected
the device to your workstation. For complete instructions, please consult the InduSoft Web
Studio User Guide. You do not need to enter a license at this time.

5) Tap OK to close the Setup dialog.
Remote Agent is now ready to receive communication from IWS running on your workstation.

Automatically Starting Remote Agent on Boot

Please keep in mind that it can be awkward to have to manually start Remote Agent on the device
every time you want to establish communication between the device and IWS on your workstation.
As such, you should configure the device to automatically start Remote Agent whenever the device
is booted. Please consult the manufacturer’'s documentation for the preferred method to automati-
cally start an application.

Installing the Remaining CEView Files

Now, with Remote Agent installed and running on the Windows CE-based device, IWS can connect
to the device and install the remaining CEView files.

To install CEView on your device:
1) On your workstation, start Indusoft Web Studio.
2) From the main menu bar, select Tools » Execution Environment. The Execution Environment dia-
log will be displayed:

Execution Environment

Target | Application | Import | CE License

Target Station

() Local Status:
O Network IP;

y Platform:
() Serial Port:

O Microsoft ActiveSync

Close

Figure 18. Execution Environment Dialog

3) Configure the Target Station settings as needed, depending on how you’ve connected the
device to your workstation. For complete instructions, please consult the InduSoft Web Stu-
dio User Guide.

4) Click Connect to establish communication with the device.

If communication is successfully established, then the Status and Platform fields will be up-
dated to reflect the connected device. Also, the Remote Agent utility on the device will show
that it has successfully connected back to IWS.

5) Click Install system files... to install the CEView files on the device.
6) When the installation is completed, click Close to close the Execution Environment dialog.

7) Reboot the device once more to save the updated files to the device’s persistent (non-
volatile) memory.
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You should now have the ADS library, the Remote Agent utility, and the CEView files all installed on
your Windows CE-based device.

Licensing CEView

You must have a valid license to run CEView beyond the free evaluation period. You can obtain this
license by contacting your InduSoft sales representative and providing the device’s “site code.” The
representative will use this site code to generate a corresponding license code, which you can then
apply to the device.

The actual licensing can be done in either of two ways: via the Execution Environment tool in IWS,
or directly at the device. If you've already used the Execution Environment tool to connect to the
device and update the CEView software (see the previous page), then it's very easy to also license
the software.

When you are ready, proceed with the following instructions:
1) In the Execution Environment dialog, select the CE License tab:

Execution Environment

| Target | Application | Import | CE License

Lizensze Settings
Product Type: | CEYiew PRO

Wergiarn: .E.E! Murnber of "Web Thin Clients: .E
Lizenze Codes
Site Code: | 7936 CFAR BC23 4549 1481 3450 BB21 2298 AA |
Site Keyw |

Cloze

Figure 19: CE License Tab in the Execution Environment Dialog

2) Copy the code given in the Site Code field and send it to your InduSoft sales representative.
Your representative will return a license key that corresponds to the site code.

= Note

The site code shown above is given only as an example. Your device’s actual site
code is generated when CEView is installed, and it is unique to your device.

3) Enter the license key in the Site Key field and click Send.

If the site key is accepted (validated), then a confirmation message will be displayed. If the
site key is not accepted, verify that you have entered it correctly and try again. If it is still
not accepted, then contact your InduSoft sales representative for assistance.
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If for whatever reason you cannot connect to the device via the Execution Environment tool in IWS,
you can still apply a license directly on the device itself:

1) On your Windows CE-based device, in the Remote Agent utility, tap Setup to open the Setup
dialog:

setup x|

Device Connection
¢ Serial Port Icgm vl Advanced... I

" TCPAP
" Infra Red

™ Run CEView on startup

Users... | Ok Cancel

Figure 20. Setup Dialog in Remote Agent

2) Tap License to open the License dialog:

x

Current License
Product Type:

|CEView Standard
Version [X.Y]):  Web Thin Clients:

Close |

Figure 21: License Dialog in Remote Agent

3) Tap Change License to open the Change License dialog:

Change License x|

Site Code
|87BB8?8786878F87808788?8A87E

Site Key:

Authorize I

Figure 22: Change License Dialog in Remote Agent

4) Copy the code given in Site Code field and send it to your InduSoft sales representative.
Your representative will return a license key that corresponds to the site code.

= Note

The site code shown above is given only as an example. Your device’s actual site
code is generated when CEView is installed, and it is unique to your device.
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5) Enter the license key in the Site Key field and click Authorize.
If the site key is accepted (validated), then the following message is displayed:

success

Site key accepted.

Figure 23: Site Key Accepted
If the site key is not accepted, verify that you have entered it correctly and try again. If it is
still not accepted, then contact your InduSoft sales representative for assistance.

When CEView is properly installed, licensed, and ready for runtime, you can proceed to
“Establishing Communication Between TwinCAT Stations” on page 25.
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Establishing Communication Between TwinCAT Stations

To establish communication between TwinCAT stations, you must assign each station — that is,
each workstation, industrial PC, embedded PC, Beckhoff PLC, or Windows CE-based device that is
running either the TwinCAT software or the ADS library — a unique station ID.

Furthermore, you must give each station a list of the other TwinCAT stations with which it is al-
lowed to communicate. Why is this necessary? Well, because TwinCAT messages are not broadcast
over the network for all stations to hear. Instead, messages are routed directly to their intended
station(s) according to the specified list.

Keep in mind that for two stations to communicate with each other, in both directions, you must
make these changes on both stations.

What is an AMS Net ID?

Each TwinCAT station must be assigned a unique station ID, which is also called an AMS Net ID.
AMS stands for “"Anlagenmanagement-System,” which is a German translation of “Plant Manage-
ment System.” It simply refers to the messaging protocol used by TwinCAT and the ADS library,
and it works on top of the physical network.

By default, a station’s AMS Net ID is automatically generated when the software is installed, by
combining the station’s existing IP address with a minimum “.1.1” suffix. For example, on a station
with the IP address 10.168.23.163, the default AMS Net ID would be 10.168.23.163.1.1.

However, you can change the AMS Net ID to whatever you need it to be, according to your Twin-
CAT system layout. This is especially important in a mixed-network system (i.e., TCP/IP and Serial)
where not all stations have IP addresses. The only requirements are that the ID must follow the
six-byte, period delimited format and it must be unique to the station.

For more information about the AMS messaging protocol, please consult Beckhoff’'s documentation.
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Editing Connection Settings in the Full TwinCAT Software

If you have the full TwinCAT development software installed on your workstation or industrial PC,
then the connection settings are completed in two parts. First, you must use the System Properties
dialog to assign an AMS Net ID to the station. Second, you must use the System Manager to
search for other TwinCAT stations on the network and add them to your router list.

Assigning an AMS Net ID
To assign the AMS Net ID in the TwinCAT System Properties dialog:
1) If the TwinCAT software is not running already, then start it now.

= Note
By default, the TwinCAT software is configured to start automatically on boot.

2) Find the TwinCAT icon in the Windows system tray:

5) 5 12:59 PM

N—
Figure 24. TwinCAT Icon in the System Tray

3) Right-click on the TwinCAT icon and select Properties from the pop-up menu:

@ About TwinCAT...

£ Log Yiew
- System Manager
PLC Control

Router

System
10
PLC

Figure 25. Opening the TwinCAT System Properties
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The TwinCAT System Properties dialog is displayed:

TwinCAT System Properties @

General | System | AMS Fouter | PLC Regiztration

TwinCAT Swvatenn Control
v2.10.0 [Build 153]
TwinCAT PLC
v2.10.0 [Build 1256]

time limited to: 7/18/2006, 11:55:29 PM
Copypright BECKHOFF © 1996-2002

Reqiztration:
Mame;
Company:
Req.-Fey

l 0K l[ Cancel ]

Figure 26. TwinCAT System Properties Dialog
4) Select the AMS Router tab:

IwinCAT System Properties @
General | Spstem | AMS Router | FDC | Registration

Local CanmpLter

AMS Met 1d: 152.168.131.66.1.1

Remote Computers

[ Add l [Hemovel [Propertiesl

[ 0K l[ Cancel ]

Figure 27. AMS Router Tab in the System Properties Dialog
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5) Check the default AMS Net ID and change it if necessary:

IwinCAT System Properties gj

General | Spstem | AMS Router | PLC | Registration

Local CanmpLter

AMS Met Id: 152.168.131.66.1.1

Remote Computers

[ Add l [Hemovel [Propertiesl

[ 0K l[ Cancel ]

Figure 28. AMS Router Tab in the System Properties Dialog
6) Click OK to apply your changes and close the TwinCAT System Properties dialog.

Adding Stations to the Router List
To search for other TwinCAT stations and add them to your router list:

1) Right-click on the TwinCAT icon in the system tray, and then select System Manager from the
pop-up menu:

@ about TwinCAT...

= Log Yiew

. » System Manager

PLC Control

Router

System
10
PLC

Properties
[ &9, % 320aM

e

Figure 29. Opening the TwinCAT System Manager
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The TwinCAT System Manager window is displayed:

“rUntitled - TwinCAT System Manager,

File Edit Actions Wiew Options Help

DEwE B S HRERN @S Qe el
+ B SvSTEM - Configuration :
BA PLC - Configuration Genersl | Boot Settings

= 1/0 - Configuration
BB 1/0 Devices

B8 Mappings TwinCAT Spstem Manager Choose Target...
|

w210 [Build 1311)

TwinCAT PLC

v2.10 [Build 1256]

tirne limited to: 741342006

Copyright BECKHOFF & 1936-2008
hittp:# Swa. beckhaff. com

Figure 30: TwinCAT System Manager

2) Click Choose Target. The Choose Target System dialog is displayed:

Choose Target System @

[ = ﬂ --|:||::-E||-“

101

Ok

Cancel

Search [Ethernet)...

Search [Fieldbuz) ..

[ 5et as Default

Figure 31: Choose Target System Dialog
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3) Click Search (Ethernet). The Add Route dialog is displayed:

Add Route Dialog X
l Enter Host Mame / 1P l [ Refresh Status (li[ Broadcast Search ] D
Host Marme Connected  Address AMS Metld TwinCaT 05 Werzion Cormment

Figure 32: Add Route Dialog

4) Click Broadcast Search. The System Manager will search the network for other TwinCAT stations
and display them. Stations to which routes have already been established will be marked:

Add Route Dialog @
[ Enter Host Name / IP: ] [ Refresh Status ] |  BroadcastSearch |
Host Name ed  Address AMS Netld TwinCAT 08 Version Comment
pc 10168.23.2.. 192168.23252... 2101246  WinXP
CX_002319 10.168.23.2.. 5.035251.1 2.9.947 ‘win CE (4.20)
SupportPC 10168.23.2.. 10168.23.2361.1  2.9.947 ‘win 2000

Figure 33: Results of Broadcast Search for Other TwinCAT Stations

5) Select a new station and click Add Route, or simply double-click on the station. You will be
prompted for a Username and Password for the station:

Logon Information

3&7\\ Enter a user name and password that is valid for the
] remote system.

User name: ladministrator

Password:

[ 0K ][ Cancel ]

Figure 34: Logon Information for the Target Station

6) Enter the Username and Password for the new station, and then click OK.

= Note

If the target station is a Beckhoff CX Series device (CX1020 or CX1000) running Win-
dows CE, then the default Username is administrator with no password.
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If the logon is successful, then the station will be marked as connected in the route list:

Add Route Dialog
[ Enter Host Name / IP: ] [ Refresh Status ] | BroadcastSearch |
Host Name Connected  Address AMS Netld TwinCAT 0S5 Version Comment

10168.23.2.. 192168.23.252... 21012468  WinXP

pc Y
CX_002319 X 10.168.23.2.. 50352511 29947 Win CE (4.20)
10168.23.2.. 10168.23.236.1.1 289947 Win 2000

SuppartP

Figure 35: Target Station is Successfully Connected

7) Repeat steps 5 and 6 for each station to which you want to establish a route.

Keep in mind that this list only shows the other TwinCAT stations to which routes have been
established, allowing communications and making those stations available to be targeted by
the TwinCAT development software. Actually targeting a station for your control program is
a separate procedure; please consult Beckhoff's documentation for more information.

8) Click Close to close the Add Route dialog and return to the Choose Target System dialog.
Stations that can be targeted for your control program are now listed here.

Choose Target System

= m ~Local-- [10.168.23.231.1.1]

+ 4 Cx_002319 (5.0.35.25.1.1)

Figure 36: Choose Target System Dialog Showing Available Stations

9) Click OK to close the Choose Target System dialog.

10)From the main menu bar in the TwinCAT System Manager window, select File » Exit to exit
the System Manager.

Your connections are now set and ready for communications. Furthermore, because you used this
method to establish your connections — that is, you searched the network and actually logged onto
the stations — there is no need to manually test them. You can proceed to "Building a Sample IWS
Application” on page 36.
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Editing Connection Settings in the TwinCAT Runtime or the ADS Library

If you have the TwinCAT runtime engine on a Beckhoff PLC, or the ADS library on any other type of
station, then you can use the AMS Remote Connections Manager utility to assign the AMS Net ID
and establish routes to other TwinCAT stations...

1) On your station, find the AMS Remote Connections Manager utility (TcAmsRemoteMgr .exe).

= Note

Even though this file is installed as part of the TwinCAT runtime engine or ADS li-
brary, it can be difficult to find since the installation of the library varies by plat-
form. For more information, please see pages 7 and 19.

You can also use the Windows Search function to find the file more quickly, but re-
member to search for the actual filename (TcAmsRemoteMgr.exe).

2) Double-click (or double-tap) on the utility to run it. The AMS Remote Connections dialog is
displayed:

AMS Remote Connections

Local Computer

AMS Net Id: [192.158.131.55.1.1

Remote Computers

Remove 1 Propeltiesl

oK Cancel

Figure 37. AMS Remote Connections Manager

3) Check the default AMS Net ID for the local station and change it if necessary.
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4) Click Add to add a new connection (route) to another TwinCAT station:

AMS Remote Connections

Local Computer

PN NP A 10.168.23.163.1.1

Remote Computers

Remove I Propelties|

Figure 38. Adding a New Route in AMS Remote Connections

The Add Remote Connection dialog is displayed:

Add Remote Connection

Name:
AMS Net Id:

Address:

Transport: TCPAP -

I Slow Connection

Caresl

Figure 39. Add Remote Connection Dialog

Before you proceed, make sure that you have the required information for the other station.

5) In the Name field, enter a descriptive name for the remote computer. For example, “Sup-
portPC” or "CX1020 #3.”

6) In the AMS Net ID field, enter the unique station ID of the remote computer.
7) In the Address field, enter the address of the remote computer on the physical network.

The format of this address depends on the type of network. For example, if the type of net-
work is Ethernet TCP/IP, then the address will be in standard four-byte, period delimited
format (ex. 10.168.23.163).

8) Click on the Transport pull-down menu and select the type of physical network.

= Note

There are many different types of physical network to choose from, and the address
format can vary greatly from type to type. If you are using a network other than
Ethernet TCP/IP, then please consult Beckhoff’s documentation and/or the hardware
manufacturer’'s documentation for more information.
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9) Click OK to accept the properties and add the connection to the Remote Computers list.
10) Repeat steps 4 through 9 for each connection (route) you want to add.

New connections are not tested as they are added. You will be able to test these connec-
tions in the next section below.

11)Click OK to close the AMS Remote Connections dialog.
12)To apply these new settings, you must restart the TwinCAT runtime engine or ADS library.

If you are working on a workstation or industrial PC running Windows NT/2000/XP, or an
embedded PC running Windows XPe, then you must completely reboot the PC.

If you are working on a Beckhoff CX1020 or CX1000, or any other Windows CE-based de-
vice, then you must save the registry and restart the device. On a Beckhoff device, simply
tap the Start button to open the Start menu and then select Suspend. On any other device,
please consult the manufacturer’s documentation.

Testing the Connections

Since you manually entered the information for your connections, you must now test those connec-
tions to make sure they are valid and able to handle communications. To test a connection:

1) On your station, find the ADS Test utility (TcAdsTest.exe).

The location of this utility can vary, depending on how the TwinCAT runtime engine or ADS
library was installed on the station. In most cases, it should be in the same directory as the
AMS Remote Connections Manager utility (TcAmsRemoteMgr.exe) described previously.

2) Double-click (or double-tap) on the utility to run it. The TcAdsTest panel is displayed.
3) Click AdsPortOpen to open the port for communication:

o R |

I GetDlIversion I

AdsPortOpen: port = 1

‘ AdsPortOpen I

| AdsPortClose |

| AdsGetLocalAddr |

| Test |

Figure 40: Opening the ADS Port for Communication
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4) Click Test to open the Test dialog:

Test
Amshletld: [ 152,168.23,210.1.1 (SUPPOR | w |

Pork: IBDI Cryile Time: IIEIEID

output |
Transfer I i Stop I
Variable
[] ByMame [ | Check val
Index Joxa0z0
Index Joco
Mame: I

Figure 41: Setting Up the Test

5) In the AmsNetId field, select the connection to be tested from the pull-down menu.

= Note

This menu should list the same stations/connections that you specified earlier using
the AMS Remote Connections Manager utility.

Also, if you want to test a specific TwinCAT port on the other station, then enter it in the
Port field. (Ports are used by various subroutines in a TwinCAT control program.)

6) Click Start to start the test. The results, including errors, are displayed in the Output field:

Test
Amshletld: [ 152.168.23,210.1.1 (SUPPOR | w |

Pork: 501 Cryile Time: IIEIEID

Output |4 successful )

i oot | stop |

Variable
[] ByMame [ | Check val
Index Joxa0z0
Index Joco
Mame: I

If the results are successful, then your AMS routing information is correct and the connec-
tion is ready for use. If the results show any errors, then check your physical cabling and
routing information and try again.

7) Click Stop to stop the current test.
8) Repeat steps 5 through 7 for each connection that you want to test.
9) Close the Test dialog and exit the ADS Test utility.

Your connections are now set and ready for communications. You can proceed to “Building a Sam-
ple IWS Application” on the next page.
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Building a Sample IWS Application

After you have installed the software, configured the communication settings, and tested the con-
nections, you are ready to build a sample IWS application that uses all of these components.

For the purposes of this section, you must have the following minimum network configuration:

Windows NT/2000/XP Beckhoff CX1000, Windows CE

i InduSoft TwinCAT i i TwinCAT InduSoft i
! Web Studio development | | ' runtime CEView .
! ' ! preinstalled '
| TWCAT ADS i TCP/IP | ADS TWCAT
i driver Library ) i Library driver :

____________________________________________________________________________

Figure 42: Network Configuration for Sample Application

Using the instructions below, you will create a IWS/CEView application screen that displays a Twin-
CAT program variable (a.k.a. PLC register) on the Beckhoff CX1000. Of course your network con-
figuration may be different than the one shown above, but the same basic instructions apply to all
possible configurations; only certain options would vary.

= Note

These instructions do not cover how to initially configure the CX1000, nor how to use the
TwinCAT development software to program the device. It is assumed that you have already
created the TwinCAT program and downloaded it to the CX1000. For more information,
please see Beckhoff's documentation for TwinCAT.

Also, please keep in mind this is only a basic walkthrough for creating a sample IWS appli-
cation. For complete instructions on using IWS, please see the IWS User Guide.

The rest of this section describes how to:
= Run InduSoft Web Studio and create a new IWS/CEView application project;
= Select the TWCAT communication driver;
» Build a driver worksheet that links an IWS database tag to the TwinCAT program variable;
= Lay out a simple IWS/CEView application screen that displays the variable;
= Compile the application and download it to the CX1000; and
= Start the CEView application.

Creating a New IWS Application

On the PC where InduSoft Web Studio is installed, create a new IWS/CEView application project:
1) Run IWS by selecting it from the Start menu or double-clicking on the desktop icon.
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2) From the main menu bar, select File » New. The New dialog is displayed:

New
File: Praject
B Alarm Worksheet S TCP Clisrt Workshest
jed DOE

Client Worksheet [ Trend Worksheet

B rMath worksheet

"5 PN Driver Worksheet
4 ODEC Wiorkshest
PPEQPC Client Workshest
A Recipe Worksheet
gﬁepor‘c Worksheet

) Scheduler Workshest
| B script warksheet

X

] [ Cancel

Figure 43: New Dialog

3) Click on the Project tab:

MNew

File Project

Application narme:
Location:

CDocuments and Settingsh

Configuration file:
C\Documents and Seftings)

Target platform:

CEWiewy Lite CEWiew PRO

Lite Interface Operator Wiorkstation
CEYiew Standard Cortral Room

Local Interface Advanced Server

iy Documentsindu?

Wy Documentsindu=oft Webh =

ak. ] [ Cahicel

4) In the Application

Figure 44: Project Tab of the New Dialog

name field, enter TWCATSample.

InduSoft Ltd.
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5) Under Target platform, select CEView Standard:

New: @
File Project

Application narme:
TWICAT Sample

Location:

ChDocuments and Settings) iy Documentsindu?

Configuration file:
C\Documents and Seftingsh Wy Documentsindu=oft Webh =

Target platform:

CEWiewy Lite CEWiew PRO

Lite Irterfac Operator Wiorkstation
CE andard Cortral Room

Local Interface Advanced Server

l Ok ] [ Cancel

Figure 45: Selecting the Target Platform

6) Click OK to proceed to the Project Wizard dialog:

Project Wizard

Template:

— Resoluti
Empty Application St

(O 240%320
(3201240
O B40% 240
(®) 640 480
(800 %600
(1024 x 768
(12801024

Shared Tags

Name: v

[ 0K ] [ Cancel ]

7) The default settings are fine for this sample application, so click OK to close the dialog.
The new application project is created in IWS and it is ready for configuration.
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Selecting the TWCAT Communication Driver

By default, all available communication drivers are installed with the IWS development software,
but they are not automatically enabled when you create a new IWS/CEView application project.
You must manually select the specific driver(s) that you need for your application. In this case, you
must select the TWCAT driver to enable communication between your IWS/CEView application and
your TwinCAT control system.

To select the TWCAT communication driver:
1) In the IWS Workspace, select the Comm tab.
2) Right-click on the Drivers folder and select Add/Remove drivers from the pop-up menu:

= g% Project: TWCATSample.APP

]
[ orC [ AddfRemove drivers ”
(] TCPiIP

a2 1Y 3 P comm
Figure 46: Right-clicking on the Drivers Folder

The Communication Drivers dialog is displayed.
3) In the Communication Drivers dialog, under Available drivers, select the TWCAT driver:

Communication Drivers

Available drivers:

DLL Description -~

TI500 Texaz Instruments [Siemensz] - Seres BO0 [TBPAITP) [MT-20...

THD THIMKEDD - Think, & Do PC Based Control [MT-CE] [«1.00]
TSTCP INDUSOFT, InduSoft Test Diiver for TCPAPINT-2000-32-CE]...

Beckhoff, T\WinCAT ADS Interface PLC [MT-2k-<P-CE] [1.06]
TR Send and receive data uzing a genial or TCPAP port[ MT-200...
LL Univerzal Library [1.04 - Beta 4]
LUNITE UNI-TELWAY, UNI-TEL WY Protocol - TSR [NT/2kPACE]...
USE USIMNA STA ELISA - Blender [MT-2000-9x] [+1.02]
WILL YILLARES - Dedicated equipment [MT/2000/P][1.00] v

Selected drivers:
DLL Description
[ ak. ] [ Cahicel

Figure 47: Selecting the TWCAT Driver

= Note

If you have not already downloaded and installed the latest version of the TWCAT driver (see
pages 4 and 7), then take a moment to note the driver version displayed in the description —
in the figure above, the driver version is 1.06 — and then compare it to the latest version
posted at www.indusoft.com.br/download/drivers/. If a newer version is available, then you
should pause here to download and install it. (You must restart IWS to make the new driver
available, so save your application project and exit IWS before you install the new driver.)
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4) With the TWCAT driver selected, click Select to add it to the Selected drivers list for the appli-
cation project:

Communication Drivers

Avwailable drivers:

DLL Description ~
TI500 Texaz Instruments [Siemensz] - Seres BO0 [TBPAITP) [MT-20...
THD THIMKEDD - Think, & Do PC Based Control [MT-CE] [«1.00]

TSTCP INDUSOFT, InduSoft Test Driver for TCRAP[NT-2000-32-CE]...
TR Send and receive data uzing a genial or TCPAP port[ MT-200...

LL Univerzal Library [1.04 - Beta 4]

UMITE LNI-TELWAY, UNI-TELWEY Protocol - TS= [NT/2kHPACE)..
USE USIMA STA ELISA - Blender [MT-2000-9x) [+1.02]

YILL YILLARES - Dedicated equipment [MT/20005P][1.00]

VIRGO Alterzys - Interface with Wirgo PC Bazed Contral [CE-SH4/%86)...  w
Selected drivers:

DLL Dregcription
TWCAT  Beckhoff, TWinCAT ADS Interface PLC [MT-2k-+P-CE][1....

[ ok ] [ Cancel ]

Figure 48: TWCAT Driver Added to Selected Drivers List

5) Click OK to close the dialog. The TWCAT driver is inserted into the Drivers folder:

| Workspace

- ‘ Project: TWCATSample.APP
= {4 Drivers

ERma ] T/ CAT
(] opC
(] TCRyIP

B I]? EQ @ Comm
Figure 49: TWCAT Driver in the Drivers Folder

The TWCAT driver is now ready for configuration. In most cases, you should not need to change
the driver's communication settings because TwinCAT communications are managed by the Twin-
CAT software (or ADS library), according to how you configured it earlier. For more information,
see “Establishing Communication Between TwinCAT Stations” starting on page 25.

As such, you can proceed directly to building the driver worksheet.
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Building the Driver Worksheet

Generally speaking, driver worksheets are used to associate database tags in IWS with device reg-
isters in your PLC or I/O. When the worksheets are processed during runtime, each tag/register
association is scanned and the values are updated, as needed. You can build multiple worksheets in
order to control which tag/register associations are scanned under what circumstances.

For a complete discussion about building driver worksheets, please consult the IWS User Guide. For
driver-specific syntax and parameters, please consult the TWCAT driver document (TWCAT.pdf)
that was installed with the driver files in the \DRV directory (see page 7).

To build a basic driver worksheet for the TWCAT driver:

1) In the Workspace, expand the TWCAT driver folder and select MAIN DRIVER WORKSHEET. Right-
click on the worksheet and select Open from the pop-up menu.

= $% Project: TWCATSample.APP
= {4 Drivers
- 5 TWCAT

ESEMAIN DRIVER S
CJoPC Open
] TCR{IP

=] 1Y 53 £ comm
Figure 50: Opening the Main Driver Worksheet

The worksheet is opened for editing:

TWCAT - MAIN DRIVER SHEET |

Drescription;

AN DRIVER SHEET

Dizable:

Fead Completed: Fead Status:

Wiite Completed: ribe Statuz O

Tag Mame Station | N2 Address Action Scan Driv Add

= Read+Write % Always b
= Read+Write % Always b
= Read+Write % Always b
= Read+Write % Always b
= Read+Write % Always b

Figure 51: TWCAT Main Driver Worksheet

The Disable, Read Completed, Read Status, Write Completed, and Write Status fields are used for check-
ing read/write status and logging runtime errors. They're not necessary for this sample ap-
plication, so you can proceed directly to making your first tag/register association.
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2) Tab down to the Tag Name field in the first row of the worksheet table, and then enter the
name of your IWS database tag:

Tag Name Station { IO Address Action Scan Div Add
* [ MyTag]| Read+Write ¥ Always v
= Read+Write ¥ Always b
- | Read+Write ¥ Always v
- | Read+Write ¥ Always b
- | Read+Write ¥ Always v

Figure 52: Entering the Tag Name

3) If the tag is not already defined in your IWS database, then you will be prompted to create
the tag now:

Question

Tag 'MyTag' does not exist.

Would you like to create this tag ?

I ves | [ No l

Figure 53: Creating a New Database Tag

Click Yes. A New Tag dialog is displayed:

New Tag
Name: MyTag
Size: 0
Type: Integer v
Description:
Scope: Server v
T [ Cancel ]

Figure 54: New Tag Dialog

Size is the number of elements, if the tag is an array (0 is not an array); Type is the type of
data (e.g., Integer, Boolean, Real, String); and Description is short description of the tag.

For this sample application, you can accept the default values for the tag, so click OK.
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4) Tab into the Station field and enter the station ID for the target PLC, I/O or control program:

’ Tag Name Station IfO Address ‘ Action
1 MyTag 192.168.1.72.1.1:1| Read+Writ
Read+Writ
Read+Writ
Read+Writ
Read+Writi

Figure 55: Entering the Station

For the TWCAT driver, the syntax of the Station field is:

<AmsNetID>:<Runtime or Port Number>

Where:
* <AmsNetID>is the AMS Net ID of the target station (see page 25);
* <Runtime> is the runtime number (1, 2, 3 or 4) of the TwinCAT control program; and

" <Port Number> is the ADS port used for the TwinCAT PLC, TwinCAT NC or TwinCAT I/0
communications. The following ports are implemented and tested in the current version
of the TWCAT driver:

o 301 — TwinCAT I/O
o 800 — BC9000
o 801, 811, 821, 831 — TwinCAT PLC on Windows NT/2000/XP or Windows CE

For more information about AMS Net IDs and TwinCAT port humbers, please consult Beck-
hoff’'s documentation.

= Note

You can also leave the Station field blank. If you do, then the driver will automatically
communicate with the first TwinCAT PLC runtime on the same workstation or device.
This is equivalent to entering a value of 127.0.0.1.1.1:801.

This feature is typically used when the same IWS application will be deployed to mul-
tiple devices; you do not need to customize the addressing for each device. How-
ever, you must have both IWS (or CEView) and TwinCAT installed and running.

5) Tab into the /0 Address field and enter the program variable or register address on the target
station:

’J Tag Name Station IFO Address Actiol
1

MyTag 192.168.1.721.1:1 MyTevar_Int16 Read+Wri
Read+Wri
Read+wri
Read+wri
Read+wri

Figure 56: Entering the I/O Address
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In this example, .MyTcVar_Intlé6 is a Global Variable defined within a TwinCAT control pro-
gram running on the target station. For more information about TwinCAT program variables
and device registers, please consult Beckhoff's documentation.

= Note

If you want to actually download and run your sample application (see page 50),
then this must be a real program variable on a real TwinCAT station. Otherwise, you
will receive communication errors during runtime.

With the Tag Name, Station and 1/0 Address fields completed, you've established an association
between the tag in your IWS database and the variable in your TwinCAT control program.
Now you must specify what action is taken and when.

6) In the Action field, click on the pull-down menu and select the type of action to be taken on

this tag:
Action
Read
Write
Read+Wirite [%
Figure 57: Selecting the Action
Where:

* Read is only read values from the target station into the IWS database;
* Write is only write values from the IWS database to the target station; and
* Read+Write is both read from and write to the target station.

7) In the Scan field, click on the pull-down menu and select when the values are scanned:

Scan

Screen
Always
X

v

Figure 58: Selecting the Action

Where:

* Screen is only when the value of the tag is changed by user input (e.g., a button press
or text entry) from your HMI screen; and

* Always iS On every execution cycle.
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8) From the main menu bar, select File » Close. You will be prompted to save the driver work-
sheet:

InduSoft Web Studio

! } Save changes to TWCAT - MAIN DRIVER SHEET?
.

[ Yes H No H Cancel l

Figure 59: Saving the Driver Worksheet

9) Click Yes to save and close the driver worksheet.

MyTag is now ready to be used in an HMI screen.

= Note

Although it is good to know how to manually build a driver worksheet, you can also use the
Import Wizard to automatically build a driver worksheet from your existing TwinCAT pro-

gram variables and communication settings. For more information, see “Advanced: Import-
ing Your TwinCAT Variables into IWS” on page 54.
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Designing the HMI Screen

You can now design an HMI screen that uses MyTag, as you defined it in the driver worksheet. For
this sample application, you’ll only add a simple text I/0 field to the screen, but the basic proce-
dure is the same for any screen layout.

1) In the Workspace, select the Graphics tab. Right-click on the Screens folder and select Insert
from the pop-up menu:

x

= 3% Project: TWCATSample.APP
B} Screens
23 Group A et
(] wWeb Pages
(] Symbols
§] Graphics Script
5 Library

= Layout

] Iy Graphics B3 E

Figure 60: Inserting a New Screen

The Screen Attributes dialog is displayed:

Screen Attrihutes E

Drescription;
Background Ficture Size Location Security:
[]Enable Background Width: | 640 Top: | 0 u
Height: | 430 Left: | o
Runtime Properties Screen Logic
|
|
Style: ReplaceiPartial) w ]
Border: | pone v
Dom't redraw:
Focuz
Receive focus on open
Share tab order with ather soreens Tab Order:| 0
[ ak ] [ Cahicel

Figure 61: Screen Attributes Dialog for New Screen

2) Enter a description for the screen, such as TWCAT Driver Test Screen. Leave the screen
Size and Location settings at their default values, and then click OK.
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The new screen (display) is opened for editing:

@ Display2 |

Figure 62: Editing a New Screen

3) From the Static Objects toolbar, select the Text tool:

2 4+ o0H

Figure 63: Selecting the Text Tool

4) Using the Text tool, click in the screen and type “This is the Value of .MyTcVar_Int16: ” fol-
lowed by six hash marks (#).

The hash marks will be used to define a dynamic text I/0 field. Six hash marks means that
the field will be six characters long.
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5) Click again on the text to highlight it.

Figure 64: Highlighting the Text Object

6) From the Dynamic Properties toolbar, select the Text I/0 tool:

D e & &
Figure 65: Selecting the Text I/O Tool

By selecting the Text I/O tool while the text object is highlighted, you are adding the Text
I/0 dynamic property to the object.

7) Right-click the text object and then choose Properties from the pop-up menu.

B IR o L
" ‘mThis is the Value of MyTcV——2= o
L . | Properties  Alt+Enter
SN i JyeT < Chri+X
S | By copy Ctri+C
STl Delete
Ll Create Linked Symbol
CLLLUI il |2y Move to back
Lol |2y Move to Front

Figure 66: Opening the Object Properties

The Object Properties dialog is displayed.
8) Click the (...) button to the right of the Tag/Expression field.

Object Properties 7
4 Hint: Text IO ¥
Taa/Expression:
[]Input Enabled Frat:
[TJE-Sign

Figure 67: Object Properties for Text Object with Text I/O
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The Object Finder dialog (a.k.a. the tag browser) is displayed:

Object Finder X

Selection:
c:ati Cancel
= Application A || Name B
I Boolean
L MyTag
e N
T =] RdE e,
Sting [ n
" Class [ Rdst
- Intemal ﬁHdT'
Functions || Tag
Log Mezsage MW'CP
Arithrnetic [=]4wiEn
Statistical [ w5t
Lagarithimiz MWrTr
Logic
Stiing
Date and Timv
[ I .
A ¥ £ 2

Figure 68: Opening a Tag Browser

9) Select MyTag from the tag list and then click OK. The tag is added to the Object Properties
dialog:

Object Propetties
= i reaio g

Tag/Expressi

[[JInput Enabled Frmt:

gl

[(JE-5ign

Figure 69: MyTag Added to Text I/O

10)Click (enable) the Input Enabled checkbox to allow the user to input a value during runtime.

Object Properties
= o Ted o v
Tag/Expression: | MyTag L

Minimum Value: | -32768 ut Enabled  Fmt:
. 5 HPassword Confirm
Maximum Value: | 32767 O Security:

[CJE-Sign Disable: 0

Figure 70: Enabling Input for Text I/O

The value is applied to MyTag in the IWS database, and from there it is written to the Twin-
CAT program variable on the target station. Also, make sure the Minimum and Maximum Values
are valid for the selected tag; e.g. a signed integer, in this instance, dictates a range of
-32768 to 32767.
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10)From the main menu bar, select File » Save. You will be prompted to give the screen a file-
name; you can change the name or accept the default (e.g., Displayl.scr). Either way,

click OK to save the screen in your project directory.

With your tag defined and your screen laid out, you can specify the screen for startup.

Specifying the Startup Screen

A single IWS application can have many different screens, so it is important to specify which screen
should be displayed upon startup. We have only one screen in this sample application, but the pro-

cedure is the same.

To specify a startup screen:

1) From the main menu bar, select Project » Settings. The Project Settings dialog is displayed.

2) Select the Runtime Desktop tab:

Project Settings

Active ares indication

Menu [Jwvirtual Kevboard:

|:| Showy P77 when guality iz not GOOD
[THide Taskbar

Identification | Options | Funtime Desktop | Communication | Web | Preferences

[

1]

l [ Cancel

3) In the Startup screen field, enter the filename of your application screen.

= Note

Workspace.

If you saved the screen with the default filename, then it should be something like
Displayl.scr. You can also check the list of screens in the Graphics tab of the

4) Click OK to close the Project Settings dialog.

You can now compile and test your application.
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Testing the Application Locally

= Note
This sample application is for education and demonstration ONLY. Do not deploy any IWS
application in a live production environment without thoroughly testing it first.

It is easy to test a sample application locally: IWS has a built-in CEView emulator that executes the
HMI screen as if it was downloaded to an actual Windows CE-based device, and the Database Spy

can show how the tag values change as the screen is used.

To test your application locally:
1) In the Database Spy, select MyTag for watching.

x

4 Mame ] Yalue ] Quality l Continuous ‘
MyTag 0 GOOD

- O

o

W

[l

1%

o

g

g4 < > '\DB1,DB2/DB3 DB/ i

Figure 71: Watching MyTag in the Database Spy

2) From the main menu bar, select Project » Run Application. The application will run locally in the
CEView emulator.

(S| CEView emulation -

File Security MWindow Tools

This is the Value of .MyTcVar_Int16: J]

Figure 72: Sample Application Running in CEView Emulator
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3) Enter a new value into the text I/O field and watch the tag change in the Database Spy.

This is the Value of .MyTcVar_Int16

x

4 Mame /Value\*Quality [ Continuous }
w | MyTag 20 BAD
4 O

o

v

P

“©

o

8

4 < > \DB1/DB2 /DB3 /DB 4/ |

Figure 73: Entering a New Value for MyTag

4) When you are done, select Project » Stop Application from the main menu bar.

= Note

If the Quality of the tag is GOOD, then the new value is successfully being written to the
TwinCAT program variable on the target station. If the Quality of the tag is BAD, then IWS
is receiving a communication error from the TWCAT driver. Check your TwinCAT communi-
cation settings and your TWCAT driver worksheet.
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Downloading the Application to a Windows CE-based Device

= Note

This sample application is for education and demonstration ONLY. Do not deploy any IWS
application in a live production environment without thoroughly testing it first.

If you've already established a connection with a Beckhoff PLC or other Windows CE-based device,
using the Execution Environment tool in IWS (see pages 14 and 21), then you can also download
your sample application to that device and run it.

1) Make sure that the Remote Agent utility (CEServer.exe) is running on the target device.

2) From the main menu bar, select Project » Execution Environment. The Execution Environment
dialog will appear. Check your Target Station settings and then click Connect.

If you cannot establish a connection with the target device, then check your physical cabling
and TwinCAT communication settings.

3) Once a connection is made, select the Application tab of the Execution Environment dialog:

Execution Environment

Target | Application | [mport | CE License

Application Path
Local | | D. Haydenhy DocumentsinduSoft Web Studio w61 Projects\TWCATSamplel

Target: ﬂ

Status:

Cloze

Figure 74: Application Tab of Execution Environment Dialog

4) Click Send To Target to download your application to the target device.

5) When the download is complete, click Run to run the application on the target device. The
Status field will display the status of your application on the device.

You can also start and stop the application by using the Remote Agent control panel on the device:

Remote Agent (v4.0)

Caonneckion status:
[Mak connected to remate client

Log:

Device connection via E =
Metwork (TCP/IP) —
Local IP; 172.16.3.91 | Exit

Figure 75. Remote Agent Running in Windows CE
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Advanced: Importing Your TwinCAT Variables into IWS

Although it is good to know how to manually build a driver worksheet (see page 41), you can also
use the database import wizard in IWS to automatically build a driver worksheet from your existing
TwinCAT program variables and communication settings.

This is considered an advanced technique for a couple reasons. First, you must configure TwinCAT
to export a file that defines all of the variables and settings that you want to import into IWS. Con-
figuring this export can be tricky, as will be described below. Second, you must carefully review the
variables after you’ve imported them into IWS, to make sure they are correct. You are more prone
to overlook errors in a worksheet built automatically from an import than a worksheet you’ve built
by hand.

Nevertheless, importing your TwinCAT variables into IWS can save a great deal of time.

= Note

This section assumes that you are already familiar with using TwinCAT to develop and de-
ploy control programs, and that you have a program ready to import into IWS. For complete
instructions on using TwinCAT, please consult Beckhoff's documentation.

Exporting a Symbol File from TwinCAT

Before you can import program variables into IWS, you must export them from TwinCAT — or
more specifically, you must export a symbol file (*.sym) that defines those variables.

To export a symbol file from TwinCAT:
1) Start the TwinCAT PLC Control programming software and open your project.
2) From the main menu bar, select Project » Options. The Options control panel is displayed.
3) From the Category menu, select Symbol configuration:

Cateqary:

Load & Save
User Information
E ditar

Desktop [ Dump =ML symbal table
Calors

Directories

Log

Bild

Pazzwaords Canfigure symbaol file .
Sournce download

™ Dump symbal entries

Syrnbol confiquration
Database-connection
Macroz

TwinCaT

Figure 76: Symbol Configuration Control Panel

4) Enable (check) the Dump symbol entries option.
5) Click the Configure symbol file button. The Set object attributes dialog is displayed.
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IWS can only import program objects (POUs) and global variables. It cannot import libraries or
other system settings, so you must make sure those items are not included in the exported file.

6) In the program directory tree, select only the POUs and Global Variables that you want to
export to IWS. (Ctrl-click to select/deselect individual items.)

Set object attributes gj
= td azchine. pra QK. |

Cancel

Figure 77: Selecting Program Objects and Global Variables for Export

7) Disable (uncheck) all export options other than Export variables of object. This will ensure that
only basic variable definitions are exported, rather than any metadata or other structures.

< [V Export variables of object
[ Export data enfries

I Export structure components
I” Export array entries

I ‘Write access

Figure 78: Disabling All Export Options

8) Click OK to accept the configuration and return to the Options control panel.
9) Click OK to close the Options control panel.

10)From the main menu bar, select Project » Rebuild All. As TwinCAT rebuilds the project, it gen-
erates the symbol file and saves it in the project directory.

The symbol file is now ready for import into IWS. It will have the same name as the project file
from which it was generated, so for a TwinCAT project named Maschine.pro, the symbol file is
named Maschine. sym.

Keep in mind that the symbol file will be regenerated every time you rebuild your TwinCAT project,

so if in the future you make changes to your project, you must consider whether you also need to
reimport the symbol file into IWS.
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Importing the Symbol File into IWS

Once you have exported your symbol file from the TwinCAT programming software, you can use
the database import wizard to import it into IWS:

1) Start the InduSoft Web Studio development software and open your application project.

2) From the main menu bar, select File » Import Wizard. The Import Wizard dialog is displayed.
3) From the Source Type menu, select TwinCAT PLC Database:

Import Wizard

Source Type:
@Indusoft@ Import Tool For PanelBuilder{Tr)
E OMROM C¥ Programmer Database
TwinCat PLC Database
= Indusoft® Impart Tool For PanelMate TH)

£

Description

Import the Tags and Communication interface from a report file
exported by TwinCat programming software,

[ Mext = ] [ Zancel

Figure 79: Selecting TwinCAT PLC Database
4) Click Next to proceed to the next step of the wizard.
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5) Enter the AMS Net ID and port number of the TwinCAT runtime, station or device with which

your IWS application will communicate. (For more information, see “Establishing Communi-

cation Between TwinCAT Stations” on page 25.)

Import TwinCat PLC Database Wizard

Options

() Do not import duplicate tags

) Replace duplicates-wi

AMS Mek 1D
192.168,131.65.1.1|

[ Use prefix:

(%) 1, Run-Time Syskem (Port: 8013
()2, Run-Time System (Pork: 5119
()3, Run-Time Syskem (Port: 8213
()4, Run-Time System (Pork: 831)

Browse, .,

Zancel

Figure 80: Specifying the AMS Net ID and Port Number

The import wizard will use this information to build the driver worksheet.

= Note

If you plan to have IWS and TwinCAT running together on the same workstation or
device, then you can specify an AMS Net ID of 127.0.0.1.1.1 and a port humber of
801. This will instruct IWS to communicate with the first TwinCAT runtime that is

running locally.

This feature is typically used when the same IWS application will be deployed to mul-
tiple devices; you do not need to customize the addressing for each device. How-
ever, you must have both IWS (or CEView) and TwinCAT installed and running on

every device.
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6) Click the Browse button to open a standard Windows file browser, and then find the TwinCAT

symbol file that you want to import into IWS. The file should be saved in your TwinCAT pro-
ject directory.

Open @gj

Look in: | [ FirstSteps " G ¥ % El,
oY IMaschine, 5

My Recent

Documents

Desktop

2

My Documents

=X
w8

iy Conputer

.F‘J File: rarne: Maszchine. 5 b
My Metwork  Files of type: VM [ 57M) v

Figure 81: Browsing for the Symbol File

7) Click Open to select the file and return to the import wizard.

Import TwinCat PLC Database Wizard @

Options
(%) Do not import duplicate tags
) Replace duplicates with tags imported

TwinCak PLC
AMS Met ID:
192.165,131.65.1.1

(#)1, Run-Time System (Port: 8013
()2, Run-Time System (Pork: 511)
()3, Run-Time System (Port: 8213
()4, Run-Time System (Pork: 831)

CATwinC AT SamplesiFirskStepsiMasching, SV

[ use prefix:

[ < Back “ Mext = ][ Zancel

Figure 82: Symbol File Selected

8) Click Next to proceed to the next step of the wizard.
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9) Review the variables (i.e., tags) exported from TwinCAT, and deselect (uncheck) any vari-
ables that you do not want to import into IWS.

Import TwinCat PLC Database Wizard @

Tag Mame 3., Type Description Address s
counk 0 Integer
deviceDown 0 Boolean
devicelp o Eoolean
devapeed ] Integer
engine o Eoolean 2
3 >
[ Check H Uncheck, ” Filker...
Status Legend
This tag will be imported, W Error

M Tag will be impaorted
M Tag can be imported

Database size
Current: | 0 Imporking: | 7 Replacing: | 0

[ < Back “ Finish ][ Cancel ]

Figure 83: Reviewing the Variables To Be Imported

10) Click Finish to proceed with the import.

Importing

Creating worksheet...

|

Figure 84: Finshing the Import Process

As the import process finishes up, it does several things for you automatically:
» Selects and configures the TWCAT communication driver;
= Creates new IWS database tags that correspond to the imported TwinCAT variables; and

= Configures the Main Driver Sheet to associate the new database tags with the TwinCAT
variables at the specified AMS Net ID.
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When it is done, it should look something like the figure below.

TWCAT - MAIN DRIVER SHEET |

Dezcription:

2N DR

Dizahle:

Fead Completed: Fead Status

Wite Completed: ribe Status: O

Tag Mame Station | IiZ Address Action Scan

1 |count 192.168.131.651.1:1 .count Read+Wirite % Ahlwvays o
2 | deviceDown 192.168.131.651.1:1 deviceDown Read+Write % Ahlwvays o
3 | devicellp 192.168.131.651.1:1 devicellp Read+Write % Ahlwvays o
4 | devBpeed 192.168.131.651.1:1 devwSpesd Read+Write % Ahlwvays o
g |engine 192.168.131.651.1:1 engine Read+Write % Ahlwvays o
6 |steps 192.168.131.651.1:1 steps Read+Write % Ahlwvays o
7T | switch 192.168.131.651.1:1 switch Read+Write % Ahlwvays o

Figure 85: Final Results of the Database Import Wizard

Make sure you thoroughly review both the TWCAT communication settings and the driver work-
sheet. If everything is satisfactory, then you can proceed to develop the rest of your IWS applica-
tion as you normally would.

For more information about using the database import wizard, please refer to “Importing a Data-
base” in Chapter 3 of the IWS User Guide.
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